Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
[SOLVED] SDK for 6.1.2 Ce GA3 doesn't deploy portlet Mirto Silvio Busico August 25, 2013 10:33 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Ahamed Hasan August 25, 2013 7:11 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Mirto Silvio Busico August 25, 2013 10:00 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Ahamed Hasan August 25, 2013 10:18 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Mirto Silvio Busico August 25, 2013 10:32 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker August 29, 2013 3:10 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Ahamed Hasan August 29, 2013 9:01 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker August 30, 2013 7:53 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Ahamed Hasan September 1, 2013 7:35 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker September 2, 2013 10:46 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Ahamed Hasan September 3, 2013 12:37 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker September 3, 2013 8:50 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Gabriel Leon Leyva September 3, 2013 9:17 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet John Pearce September 4, 2013 10:12 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet James Falkner September 4, 2013 11:40 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker September 4, 2013 1:19 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet James Falkner September 4, 2013 2:10 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker September 4, 2013 2:17 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Charles Austin September 4, 2013 3:07 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker September 5, 2013 5:46 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Joan Fluvia January 14, 2014 5:10 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Rob Silver September 26, 2013 6:28 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 20, 2013 9:30 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 20, 2013 10:34 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 20, 2013 11:03 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 20, 2013 1:32 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 20, 2013 2:01 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 20, 2013 2:58 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 20, 2013 3:49 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 20, 2013 6:52 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 21, 2013 6:43 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 21, 2013 7:07 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 21, 2013 7:34 AM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet gordon daniels October 29, 2013 8:02 PM
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet Jack Bakker October 30, 2013 9:11 AM
Mirto Silvio Busico
[SOLVED] SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 25, 2013 10:33 AM
Answer

Mirto Silvio Busico

Rank: Regular Member

Posts: 129

Join Date: January 18, 2012

Recent Posts

Hi all,
I'm trying to use the 6.1.2 CE GA3 portal and the corresponding SDK.
To be sure I don't have upgrading problems, I have done a fresh install of potral and sdk.

My framework:
  • Kubuntu 13.04 64Bit
  • portal liferay-portal-tomcat-6.1.2-ce-ga3-20130816114619181.zip
  • SDK liferay-plugins-sdk-6.1.1-20130816114619181.zip


I installed portal in
/LH/bundles/612cega3

I installed SDK in
/LH/plugins/SDK

As for the 6.1 documentation I created a build.USERNAME.properties file containing:
1app.server.type=tomcat
2app.server.dir=/LH/bundles/612cega3/tomcat-7.0.40/


With these settings, when I create a portlet and give an "ant deploy" command, the portlet war is created in
/LH/plugins/bundles/deploy/
that is the wrong path; so the portlet is not hot deployed
I mean
Adding the parentdir parmeter in the build.USERNAME.properties file; I mean:
1app.server.type=tomcat
2app.server.dir=/LH/bundles/612cega3/tomcat-7.0.40/
3app.server.parent.dir=/LH/bundles/612cega3


the "ant deploy" command copies the portlet war in
/LH/bundles/612cega3/deploy

and the portlet is correctly deployes.

I'm doing something wrong?
There is any documentation update?
Ahamed Hasan
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 25, 2013 7:11 AM
Answer

Ahamed Hasan

Rank: Expert

Posts: 306

Join Date: April 13, 2007

Recent Posts

Mr.Mirto,

What you are doing is perfectly right and as per the documentation for 6.1.1 CE GA2. Just curious to know if you are facing any problems? Kindly lemme know.


Yours truly,
Ahamed Hasan
Author, Liferay Portlet Cookbook
Mirto Silvio Busico
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 25, 2013 10:00 AM
Answer

Mirto Silvio Busico

Rank: Regular Member

Posts: 129

Join Date: January 18, 2012

Recent Posts

Thanks for your interest.

I'm just starting with the development, so I'll post any problem I'll encounter.

If you can point me to relevant documentation I'll much appreciate it.

The documents I use are:
  • online guides for 6.1
  • the "Liferay in action" book
  • some blog articles


My development framework is:
  • Kubuntu 13.04 64bit running on a dedicated virtual machine used for Liferay development
  • openjdk-7-sdk java
  • eclipse kepler (from eclipse site: I was not able to work with Liferay IDE on eclipse distributed with kubuntu)
  • 6.1.2 Ce GA3 Liferay portal
  • 6.1.2 sdk (but the downloaded file reports 6.1.1.in the name)
  • 1.6.2 Liferay IDE (I have to install again for 6.1.2 - for 6.1.1 it seemed to work but I had some problems with generating a theme)


The path for development I'm following is:
  • Install portal, sdk and ide (done)
  • test I'm able to generate and deploy a portlet from sdk (done)
  • test I'm able to create and deploy a portlet with eclipse/ide (to do)
  • create a theme that follow my customers standard (I'm an ICT consultant)
  • develop a portlet that executes an arbitrary operating system command and dysplays the command results


Why I'm doing this?
I'm trying to convert two projects I have done using Plone/Python to new implementations using Liferay/java

Any suggestion, hint, link or other is welcome.

Thanks
Mirto
Ahamed Hasan
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 25, 2013 10:18 AM
Answer

Ahamed Hasan

Rank: Expert

Posts: 306

Join Date: April 13, 2007

Recent Posts

This is perfect Mirto,

You can use Sun Java SDK instead of OpenJDK as there are some issue being face while using this JDK.

You can also refer to my book if required.

I can definitely help you if you can give me specific requirements.
Mirto Silvio Busico
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 25, 2013 10:32 AM
Answer

Mirto Silvio Busico

Rank: Regular Member

Posts: 129

Join Date: January 18, 2012

Recent Posts

Thanks
Mirto
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 29, 2013 3:10 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

The downloads for v6.1 GA3 including at sourceforge reference v6.1.1 SDK not v6.1.2 SDK

Where is the v6.1.2 SDK ?
Ahamed Hasan
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 29, 2013 9:01 PM
Answer

Ahamed Hasan

Rank: Expert

Posts: 306

Join Date: April 13, 2007

Recent Posts

Yes, i think the links is the main site is still not updated properly.

In the interim, you can download the actual files from http://releases.liferay.com.

ours truly,
Ahamed Hasan
Author, Liferay Portlet Cookbook
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
August 30, 2013 7:53 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Hi Ahmed, releases.liferay.com link to sourceforge where v6.1.2 SDK is not found
Ahamed Hasan
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 1, 2013 7:35 PM
Answer

Ahamed Hasan

Rank: Expert

Posts: 306

Join Date: April 13, 2007

Recent Posts

Try this link Jack,

http://sourceforge.net/projects/lportal/files/Liferay%20Portal/6.1.2%20GA3/

Yours truly,
Ahamed Hasan
Author, Liferay Portlet Cookbook
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 2, 2013 10:46 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Ahmed, your various links all lead to the same place (sourceforge) where only v6.1.1 SDK is found
Ahamed Hasan
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 3, 2013 12:37 AM
Answer

Ahamed Hasan

Rank: Expert

Posts: 306

Join Date: April 13, 2007

Recent Posts

Jack,

It is strange and confusing. I am able to get to the correct download page. Try refreshing your browser. May be there is a caching issue.

Yours truly,
Ahamed Hasan
Author, Liferay Portlet Cookbook
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 3, 2013 8:50 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

I get the correct download page too at sourceforge, note that the SDK referenced is v6.1.1 and not v6.1.2 ; I think you are missing what I am saying Ahmed.
Gabriel Leon Leyva
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 3, 2013 9:17 AM
Answer

Gabriel Leon Leyva

Rank: Regular Member

Posts: 243

Join Date: June 20, 2009

Recent Posts

yes same here sdk 6.1.1
John Pearce
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 10:12 AM
Answer

John Pearce

Rank: New Member

Posts: 3

Join Date: August 13, 2013

Recent Posts

Jack,
Although the SDK is named 6.1.1 it appears to be a 6.1.2 sdk. Also, I've found that you have to update liferay-versions= in liferay-plugin-package.properties to include 6.1.2. to get the deploy to work.
James Falkner
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 11:40 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

John Pearce:
Jack,
Although the SDK is named 6.1.1 it appears to be a 6.1.2 sdk. Also, I've found that you have to update liferay-versions= in liferay-plugin-package.properties to include 6.1.2. to get the deploy to work.


John is correct - Liferay made a decision not to rename the SDK, but instead to further underscore the compatibility between 6.1.1 and 6.1.2. In fact, it should have just been a "6.1 SDK" that would work (and potentially get updates) for all 6.1.x releases, but that may have been too drastic. My guess is that the 6.2 SDK will be named the 6.2 SDK, not any particular version within. Liferay engineering has put a lot of work into compatibility this last release, and it should only get better.

Also, the default setting for newly created projects using this SDK is liferay-versions=6.1.1+ so it should be fine to deploy to 6.1.2 with no need to update any properties files.
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 1:19 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

James, is it the same SDK as you seem to imply ? if so then just changing liferay-plugin-package.properties liferay-versions=6.1.1 to 6.1.1+ should suffice ?
James Falkner
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 2:10 PM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Jack Bakker:
James, is it the same SDK as you seem to imply ? if so then just changing liferay-plugin-package.properties liferay-versions=6.1.1 to 6.1.1+ should suffice ?


Oh no, it is most certainly *not* the *same* SDK, it is a much better one! emoticon You can also see the initial download size of the Plugins SDK has drastically been reduced (it is only 10MB now, but it used to be 23Memoticon, thanks to LPS-31936.

If you look inside the new Plugins SDK, you can see the default version setting here: liferay-plugins-sdk-6.1.1/tools/portlet_tmpl/docroot/WEB-INF:
1liferay-versions=6.1.1+
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 2:17 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

thanks for clarification ; this is kinda wacky tho ; why not name the downloadable file with *6.1.2 in sourceforge and set liferay-plugin-package.properties liferay-versions=6.1.1+

just my two cents, tho in Canada they retired the penny, so even a penny for your thoughts is no longer a valid currency
Charles Austin
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 4, 2013 3:07 PM
Answer

Charles Austin

LIFERAY STAFF

Rank: New Member

Posts: 4

Join Date: January 28, 2011

Recent Posts

Hey everyone, I'm the guy responsible for building our release files, so I'll try to clear things up and explain our decisions here.

The reason the plugins SDK zip is labeled as version 6.1.1 for this release is because for GA3, we took a somewhat different approach with the portal and plugins. The portal was bumped up in its version number to 6.1.2, while plugins were simply designated as 6.1.1+ so they would remain compatible with both the existing 6.1.1 portal and the new 6.1.2 release. Essentially, our plugins for this build were version 6.1.1, while our portal was 6.1.2. If we were distributing plugins the old fashioned way instead of using Marketplace like we're doing now, you'd see that all the plugins have 6.1.1 in their file names.

The reason the plugins SDK is sort of the black sheep on that list of files linked above is because it's the only file that's built from the plugins repository, and thus it carries the plugins version both internally and in its file name. Originally we were planning to rename it to match the portal version so it doesn't look out of place, but that really wouldn't be accurate with what it actually is. The "GA3" versus "GA2" should be enough to distinguish this one from the previous one. I guess we could set its version as 6.1.1+ but that's kind of ugly, and it would probably have some annoying side effects in our scripts due to + being a regex special character.

That doesn't mean we're not up for suggestions, though. If this turns out to be really unpopular or causes issues for people, just let us know. emoticon
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 5, 2013 5:46 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

given sdk is actually a new release, my vote is for sdk to have 6.1.2 in downloadable filename where (behind the scenes?) it just supports 6.1.1+ (backward-compatable-like)

(there is no GA3 in filename, only visible via links)

best wishes wrt your responsible guy black sheep build challenges ; will now check it again now that I know the following file is the one I need for v6.1.2 liferay-plugins-sdk-6.1.1-20130816114619181.zip
Rob Silver
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
September 26, 2013 6:28 PM
Answer

Rob Silver

Rank: Junior Member

Posts: 47

Join Date: June 20, 2013

Recent Posts

I would just like to clarify.
You mean that the liferay-plugins-sdk-6.1.1 folder can be used with Liferay GA 6.1.2 CE so long as the file:
liferay-plugin-package.properties file is changed to:
liferay-versions=6.1.1+

from the original line: liferay-versions=6.1.1
??
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 9:30 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Hi, I've tried the suggestions in this post but nothing works. I can copy the war file from sdk/dist directory to /liferay/deploy directory and then it will deploy, but running ant does not deploy to /liferay/deploy directory.

6.1.2 ga2 works fine. Has anyone come up with a solution?

thanks
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 10:34 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Hi Gordon,

I had to add the following to my C:\liferay\*clientname*\workspace_*clientname*612\liferay-plugins-sdk-6.1.1\build.jbakker.properties

app.server.parent.dir = C:\\liferay\\*clientname*\\liferay-portal-6.1.2-ce-ga3

Without that line the wars were landing in C:\liferay\*clientname*\workspace_*clientname*612\bundles\deploy

(of course Mirto pointed this out in his original post to this thread...)

(I have deleted some posts I made to this thread as they were useless and likely misleading : I had copied from Linux to Windows and ended up with all sorts of strange issues not relevant to the subject at hand)
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 11:03 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Jack: thaks for replying. That's not working for me.
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 1:32 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

gordon daniels:
I can copy the war file from sdk/dist directory to /liferay/deploy directory and then it will deploy, but running ant does not deploy to /liferay/deploy directory.

can you tell me where the .war is ending up when you run the ant deploy task ? is it landing in *sdk*/bundles/deploy ?

also I gave syntax for Windows, for linux or osx is slightly different... which platform are you on ?
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 2:01 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Hi Jack:

it ends up in /sdk/dist directory. I am on linux (ubuntu) running java1.6_45, ant 1.9. No error messages. I've gone back to ga2. This is wasting too much of my time :-)

thanks for your help
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 2:58 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Hi Gordon

Yeah, I had to give up too just after GA3 came out as clients were pressing me just to 'show' progress over GA2. But since then I've been pressured to get this going over GA3 and have done 3 dev upgrades to GA3 and they all seem to be working.

just an ant 'build' would indeed just put the war only in the sdk/dist folder, but the deploy task should build then put it in ${app.server.parent.dir}/deploy which is why I set

app.server.parent.dir = C:\\liferay\\*clientname*\\liferay-portal-6.1.2-ce-ga3

on linux I have likes of

app.server.parent.dir = /opt/liferay/*clientname*/liferay-portal-6.1.2-ce-ga3

I am guessing the above additional line is not there properly in your /sdk/build.gdaniels.properties file

also make sure I didn't screw you up with a previous misleading post ; the below is the default portal.properties which should be fine

auto.deploy.deploy.dir=${liferay.home}/deploy

but might not be fine if you upgraded as $liferay.home might not be set properly - if you upgraded and have setup.wizard.enabled=true in portal-setup-wizard.properties ; try setting it to setup.wizard.enabled=false, and smack it again

smack to me means one of two things: 0) on failure: the sound of mouse hitting its head against a wall in a maze 1) on success: smakelijk (Dutch for tasty or delicious) as in semblance of successfully chasing the cheese
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 3:49 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Jack: your post had me laughing. I've done all the things you have mentioned but time is running out for me. I need to deliver a finished theme in the next couple of days, so ga2 it is. Thank you for taking time to help me. It means alot to me. Have a good evening.
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 20, 2013 6:52 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Gordon: while I gather you are on back on the ga2 track deferring ga3 ; when you get back to it, perhaps this helps:

I had a workspace_*client*611 and then created a new workspace_*client*612

I copied all plugins (themes, portlets, layouts) from workspace_*client*611/*sdk*/* into new workspace_*client*612/*sdk*/*

and then, in the new workspace, I used the IDE feature "New Liferay Project from Existing Source" over and over selecting each plugin (thanks Greg and IDE team for this feature) ; I noticed that for themes the compatibility version in liferay-look-and-feel.xml was updated automagically to 6.1.2+

but then for all theme/layout/portlet plugins I had to update manually liferay-plugin-package.properties to update liferay-versions=6.1.1 to liferay-versions=6.1.1+

(I will save you the gory git management details on all this amongst 3 developers)

Good to laugh now and then my fellow mouse. Good luck with your theme project.
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 21, 2013 6:43 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Jack: I did similiar steps. I actually can use ga3 if I copy war from sdk to 'deploy' directory. But that is such a pain. I will pick it back up next week. I don't use the IDE, tried it about three years ago and it was buggy so went to sdk. Buggy too :-) but not as much. I keep meaning to try it again. In fact David was encourging me to use it on a previous post. So, I will try next week.

thanks again for your help
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 21, 2013 7:07 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

For me in the grand scheme of things the IDE is very productive. Sounds again tho as you don't have your build.gdaniels.properties set properly to point to where to put the war on ant deploy. Let's pause this discussion till you've had time to dig.
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 21, 2013 7:34 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

You may be right. Next week will let you know out comes.

thanks
gordon daniels
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 29, 2013 8:02 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 735

Join Date: August 23, 2008

Recent Posts

Jack: : Success!!!! I have it working now. Found a slight mistake in build.gordon.properties file. Re-reading this whole thread and your invaluable help - explanations; I got it working. Yeah!

thanks Jack!
Jack Bakker
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
October 30, 2013 9:11 AM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 883

Join Date: January 3, 2010

Recent Posts

Cool !
Joan Fluvia
RE: SDK for 6.1.2 Ce GA3 doesn't deploy portlet
January 14, 2014 5:10 AM
Answer

Joan Fluvia

Rank: New Member

Posts: 10

Join Date: November 6, 2013

Recent Posts

For someone (like me) that has previously installed the 6.1.1 plugin version of the 6.1.1 GA2 can be a little troublesome...
I saw the same name so I supposed that it was the same plugin. It didn't occurred to me that it can be a diferent version with the same name. Until an error of incompatibility is arised. At first I changed the value in liferay-plugin-package.properties from 6.1.1 to 6.1.2 but luckily I found this post to clarify and download the correct plugin (and renamed it to 6.1.2 to not mess with the other one) emoticon