Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Antonio Benvenuto
Portlets randomly in session expired - IceFaces 1.8.2 - Liferay 5.2.3
June 23, 2011 9:19 AM
Answer

Antonio Benvenuto

Rank: New Member

Posts: 12

Join Date: June 19, 2011

Recent Posts

Hi

I have a big problem with Liferay 5.2.3 and IceFaces 1.8.2:

I have 5 portlets developed with IceFaces 1.8.2 in Liferay. Randomly one or more portlets ho in Session Timeout.

My portletes are deplyed as separate WAR archive and have a PRIVATE SESSION.
IPC was implemented via Liferay.trigger and Liferay.binding ajax function.

In tomcat server.xml i have setted empty-session-path = true

Some suggestions?
David H Nebinger
RE: Portlets randomly in session expired - IceFaces 1.8.2 - Liferay 5.2.3
June 23, 2011 11:41 AM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 11793

Join Date: September 1, 2006

Recent Posts

Well, the portal itself will define it's servlet session times in the ROOT/WEB-INF/web.xml, and that (I believe) becomes the basis for the portlet session times.

Even though your portlets are deployed in separate wars, the session times defined in their own web.xml files would only affect any servlets defined within the war, and should not apply to the portlets running within the portal.

Liferay suggests, I believe, to allow for auto-extending sessions through a low timeout value and auto extend parms defined in portal-ext.properties.

Here's an example from 6.0.6 (should be relatively the same in 5.2.3, but YMMV):

1#
2# Session settings
3#
4session.timeout=5
5session.timeout.warning=1
6session.timeout.auto.extend=true
7session.timeout.redirect.on.expire=false
8session.enable.persistent.cookies=true


This should fix any possible session issues that you're seeing...
Antonio Benvenuto
RE: Portlets randomly in session expired - IceFaces 1.8.2 - Liferay 5.2.3
June 23, 2011 3:09 PM
Answer

Antonio Benvenuto

Rank: New Member

Posts: 12

Join Date: June 19, 2011

Recent Posts

Hi

Thank you for suggestion,but these liferay settings not solve the problem.

I noticed this problem occurs frequently when I try to switch user.