Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Bruno Almeida
Problem getting "instance-id" attribute from velocity
January 25, 2011 2:48 AM
Answer

Bruno Almeida

Rank: New Member

Posts: 2

Join Date: November 9, 2010

Recent Posts

Hi all,

I have a structure/content like this:

<root>
<dynamic-element instance-id="60DDfQX9" name="parte" type="ContentPart" index-type="">
<dynamic-element instance-id="8I8RQWzK" name="field1" type="text" index-type="">
<dynamic-content><![CDATA[02]]></dynamic-content>
</dynamic-element>
<dynamic-element instance-id="4kVjQGMP" name="separator" type="text" index-type="">
<dynamic-content><![CDATA[Titulo Separador]]></dynamic-content>
</dynamic-element>
<dynamic-element instance-id="tKLRAB3K" name="html" type="text_area" index-type="">
<dynamic-content><![CDATA[<p>&nbsp;Olá</p>]]></dynamic-content>
</dynamic-element>
<dynamic-content><![CDATA[]]></dynamic-content>
</dynamic-element>
</root>

and I'm able to get the "type" attribute from velocity like this $parte.type. Nevertheless, the same attempt on "instance-id" ($parte.instance-id) is not successfull.
Can anyone tell me what I'm doing wrong or advise me on another way to do this?
Tks in advance for any help provided.
Bruno
Robert Kornmesser
RE: Problem getting "instance-id" attribute from velocity
July 18, 2012 1:41 PM
Answer

Robert Kornmesser

Rank: Junior Member

Posts: 39

Join Date: November 3, 2011

Recent Posts

Hi, same problem here. Is there any way now in 6.1.10 EE to solve this issue?

Participate in the State of Liferay Community 2017. Help the community and even win some prizes!