Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Balázs Jilling
Login with Facebook account does not work
December 18, 2010 5:04 AM
Answer

Balázs Jilling

Rank: Junior Member

Posts: 32

Join Date: November 18, 2010

Recent Posts

Hi,

Creating a liferay user account with my facebook account works fine, but after that if I click on the facebook button at the login portlet the following happens:

- I get redirected to facebook to login if i don't have an active facebook session in my browser, it's ok.
- After that I get redirected to the Liferay page where I have started from but i don't get logged in.

The same happens if I have a facebook session without the redirect to facebook.

What can be wrong?

(I use Liferay 6.0.5)

Thanks,
Balázs
Gaurav Jain
RE: Login with Facebook account does not work
February 16, 2011 10:17 PM
Answer

Gaurav Jain

Rank: Regular Member

Posts: 146

Join Date: January 31, 2011

Recent Posts

I am facing the same problem with same liferay version.

Any solution?
Gaurav Jain
RE: Login with Facebook account does not work
February 16, 2011 10:47 PM
Answer

Gaurav Jain

Rank: Regular Member

Posts: 146

Join Date: January 31, 2011

Recent Posts

I am getting following error when trying to do facebook login:
 1
 2ERROR [jsp:154] com.liferay.portal.security.auth.PrincipalException: /home?p_auth=TtY5d06h&p_p_id=58&p_p_lifecycle=1&p_p_state=normal&p_p_mode=view&p_p_col_id=column-1&p_p_col_count=1&_58_struts_action=%2Flogin%2Ffacebook_connect&_58_redirect=http%3A%2F%2Fdemo.componence.com%2Fhome%3Bjsessionid%3D41F0CD9814F2575F89983DED0100F5C1%3Fp_p_id%3D58%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-1%26p_p_col_count%3D1%26_58_struts_action%3D%252Flogin%252Ffacebook_connect_add_user
 3      at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:164)
 4      at com.liferay.portlet.StrutsPortlet.processAction(StrutsPortlet.java:186)
 5      at com.liferay.portlet.FilterChainImpl.doFilter(FilterChainImpl.java:70)
 6      at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:48)
 7      at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:652)
 8      at com.liferay.portlet.InvokerPortletImpl.invokeAction(InvokerPortletImpl.java:687)
 9      at com.liferay.portlet.InvokerPortletImpl.processAction(InvokerPortletImpl.java:360)
10      at com.liferay.portal.action.LayoutAction.processPortletRequest(LayoutAction.java:768)
11      at com.liferay.portal.action.LayoutAction.processLayout(LayoutAction.java:571)
12      at com.liferay.portal.action.LayoutAction.execute(LayoutAction.java:229)
13      at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
14      at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
15      at com.liferay.portal.struts.PortalRequestProcessor.process(PortalRequestProcessor.java:152)
16      at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
17      at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
18      at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
19      at com.liferay.portal.servlet.MainServlet.callParentService(MainServlet.java:508)
20      at com.liferay.portal.servlet.MainServlet.service(MainServlet.java:485)
21      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
22      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)


I am using liferay version ce 6.0.5
I added a facebook application.
Enabled facebook login and updated add_id,secret_key,redirect_url.

Now on login portlet, clicked to facebook login.. redirected to facebook.. allowed my app, back to my portal, clicked add account button. then after it redirected me back to sign in page without making me signed in.
And with this exception in the logs.

However my user has been added in the users table.
Adam Eri
RE: Login with Facebook account does not work
August 2, 2011 12:55 PM
Answer

Adam Eri

Rank: New Member

Posts: 1

Join Date: August 2, 2011

Recent Posts

Hey,
Did you find a solution for this one?
Köszi,
Adam
Andrey Filippov
RE: Login with Facebook account does not work
August 23, 2011 9:29 AM
Answer

Andrey Filippov

Rank: New Member

Posts: 23

Join Date: October 21, 2010

Recent Posts

Hi,
I've just met the same issue.. Did you have a chance to resolve it?

Appreciate.
Marcin sa
RE: Login with Facebook account does not work
June 28, 2012 4:55 AM
Answer

Marcin sa

Rank: New Member

Posts: 21

Join Date: June 27, 2012

Recent Posts

Anyone solved?
Mazhar Alam
RE: Login with Facebook account does not work
September 17, 2012 12:08 AM
Answer

Mazhar Alam

Rank: Regular Member

Posts: 201

Join Date: November 25, 2011

Recent Posts

Any solutions??
Mika Koivisto
RE: Login with Facebook account does not work
September 17, 2012 2:11 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1512

Join Date: August 7, 2006

Recent Posts

If I remember correctly the facebook login in 6.0 requires a verified facebook account so that might be the cause.
John Monk
RE: Login with Facebook account does not work
February 18, 2014 7:28 PM
Answer

John Monk

Rank: New Member

Posts: 3

Join Date: February 16, 2014

Recent Posts

We are having the same issue. Everything works fine but user is redirected to Liferay Login portlet after FB auth. Any resolution to this on 6.1.1 GA2?
Mika Koivisto
RE: Login with Facebook account does not work
February 19, 2014 10:16 AM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1512

Join Date: August 7, 2006

Recent Posts

It works in 6.1.1. Just make sure your FB account is verified or uncheck the require verified account on FB login configuration.