Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Eltaeb Beatle
Spring MVC Portlet not registering in Liferay 6
October 12, 2010 1:44 AM
Answer

Eltaeb Beatle

Rank: New Member

Posts: 1

Join Date: October 12, 2010

Recent Posts

I've developed a simple portlet using the Spring MVC Portlet framework into a Liferay 6 server running on Tomcat.

When I deploy the war-file of the portlet, I get the following log information:

-- From Liferay server
12-okt-2010 8:38:39 org.apache.catalina.startup.HostConfig deployWAR INFO: Deploying web application archive spring_sample_portlet.war

-- From Portlet application
08:38:39,859 INFO [ContextLoader:187] Root WebApplicationContext: initialization started
08:38:39,900 INFO [XmlWebApplicationContext:456] Refreshing Root WebApplicationContext: startup date [Tue Oct 12 08:38:39 GMT 2010]; root of context hierarchy
08:38:39,960 INFO [XmlBeanDefinitionReader:315] Loading XML bean definitions from ServletContext resource [/WEB-INF/applicationContext.xml]
08:38:40,045 INFO [DefaultListableBeanFactory:549] Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@45ac89: defining beans ; root of factory hierarchy
08:38:40,074 INFO [ContextLoader:214] Root WebApplicationContext: initialization completed in 213 ms


It looks like the deployment has succesfully been completed, but there is no message that the portlet is registered in Liferay like:
08:09:42,197 INFO [PortletHotDeployListener:220] Registering portlets for my-greeting-portlet
08:09:42,307 INFO [PortletHotDeployListener:369] 1 portlet for my-greeting-portlet is available for use


It also doesn't show up in the list of portlets you can add to a page.

Has anybody had a similar problem? If you need extra information from me, let me know.
Doruk Calki
RE: Spring MVC Portlet not registering in Liferay 6
January 14, 2013 11:19 AM
Answer

Doruk Calki

Rank: New Member

Posts: 1

Join Date: January 2, 2013

Recent Posts

Have you found a solution to this problem? I have several Spring MVC portlets and the war seems to be deployed properly but the portlets don't register.
Gwowen Fu
RE: Spring MVC Portlet not registering in Liferay 6
January 14, 2013 11:37 AM
Answer

Gwowen Fu

Rank: Expert

Posts: 315

Join Date: December 27, 2010

Recent Posts

Do you have this in your web.xml file?

<listener>
<listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
</listener>
David H Nebinger
RE: Spring MVC Portlet not registering in Liferay 6
January 14, 2013 11:43 AM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 11046

Join Date: September 1, 2006

Recent Posts

Do you have the portlet.xml and liferay-portlet.xml files in the WEB-INF folder? Do you have the liferay-display.xml file that determines where in the menu it should show up?