Combination View Flat View Tree View
Threads [ Previous | Next ]
dog bert
OpenSSO
February 7, 2008 6:23 PM
Answer

dog bert

Rank: New Member

Posts: 20

Join Date: February 7, 2008

Recent Posts

Taking a look at the release notes, Brian Chan has added support for OpenSSO inside of Liferay.

This all seems to be working except that the users are not created when one creates a user in the OpenSSO manager does not create the user for liferay or pull information for such a thing. If the user was already created in Liferay and in OpenSSO then it seems to log in just fine.

Was the code to create a user for Liferay added? Or am I just completely off and there shouldn't be a need to create the user since the LDAP datastore has the user and OpenSSO/Liferay should be pulling the user's information/privileges/rights from the LDAP datastore?

Thanks.
Jorge Ferrer
RE: OpenSSO
February 20, 2008 10:03 AM
Answer

Jorge Ferrer

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2768

Join Date: August 31, 2006

Recent Posts

Hi,

I don't know the answer to this question but if you've not done so already you may want to read the blog post by Brian and the one linked from it from a guy of SUN. It might give you some insight on the OpenSSO integration:
http://www.liferay.com/web/bchan/home/blogs/liferay_integration_with_opensso
dog bert
RE: OpenSSO
February 27, 2008 3:44 PM
Answer

dog bert

Rank: New Member

Posts: 20

Join Date: February 7, 2008

Recent Posts

Hi Jorge,

I did take a look at both Brian's and the SUN blog with all the instructions. I'm just wondering what "entering the right settings" is. I'm sure Brian wouldn't just put code out in production that doesn't work right? There was testing involved. The problem really seems to be that there's no documentation on what the "right settings" are. If the code works, that is.

Taking apart the code, it does seem to be doing what it should. However, if you see this post, there does seem to be a problem somewhere.

Help would be greatly appreciated as to resolving this issue.
Jorge Ferrer
RE: OpenSSO
February 28, 2008 7:05 AM
Answer

Jorge Ferrer

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2768

Join Date: August 31, 2006

Recent Posts

Hi,

I would try posting a comment in one of those two blog entries.
dog bert
RE: OpenSSO
February 28, 2008 11:22 AM
Answer

dog bert

Rank: New Member

Posts: 20

Join Date: February 7, 2008

Recent Posts

Jorge Ferrer:
Hi,

I would try posting a comment in one of those two blog entries.


I'll give that a try, but I'm not going to expect responses from those as the posts are really old.

Is there any other way to get the issue noticed?
Prashant Dighe
RE: OpenSSO
May 23, 2008 6:25 PM
Answer

Prashant Dighe

Rank: New Member

Posts: 20

Join Date: December 20, 2007

Recent Posts

Sorry for taking this long, but this has now been fixed on the trunk
http://wiki.liferay.com/index.php/OpenSSO_Integration
dog bert
RE: OpenSSO
May 27, 2008 11:44 AM
Answer

dog bert

Rank: New Member

Posts: 20

Join Date: February 7, 2008

Recent Posts

Prashant Dighe:
Sorry for taking this long, but this has now been fixed on the trunk
http://wiki.liferay.com/index.php/OpenSSO_Integration


Great! Thanks Prashant. I look forward to testing it out once 5.0.2 gets released. emoticon
nikhil kshirsagar
RE: OpenSSO
May 4, 2011 10:08 AM
Answer

nikhil kshirsagar

Rank: Junior Member

Posts: 27

Join Date: April 28, 2011

Recent Posts

Hello all,

I am working with liferay 5.1.1 in tomcat 6.0.26 (copied over root folder of liferay, etc etc .. ) and its working fine. I want to integrate this with opensso. My question is, will I need auto login hook, what is that exactly for, and is it already implemented or do I need to implement it?

I am following the steps at http://www.objectpartners.com/2010/08/16/integrating-opensso-openam-with-liferay-portal-on-tomcat/ for this exercise, if there is anything else I need to do apart from it, please do let me know..

Thanks and hope to hear from someone soon!
Nikhil.