Forums

Home » Liferay Portal » Deutsch

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Martin Mintal
PlugIn Installer // Proxy ?
February 4, 2008 6:22 AM
Answer

Martin Mintal

Rank: New Member

Posts: 1

Join Date: February 1, 2008

Recent Posts

Liferay 3.6.1 bzw. Liferay 4.4 (das Problem kommt bei beiden Versionen auf)
Tomcat 6.0
jdk1.6.0_03
jre1.6.0_03
Firefox 2.0

----------------------------------------------------------------------------------------------------------------------------------------------------------------

Hallo,

ich habe eine Frage bzgl. des PlugIn Installers. Die Configuration des Portlets habe ich nicht geändert. Immer wenn ich neue PlugIns aussuchen will, bekomme ich schlicht folgende Fehlermeldung: An error occurred while retrieving available plugins.

Tomcat-Console sagt:
14:10:59,937 WARN [jsp:124] Unable to communicate with repository http://plugins.liferay.com/official
14:11:00,078 WARN [PortletLocalServiceImpl:142] Portlet not found for 10095 40
14:11:00,203 WARN [PortletLocalServiceImpl:142] Portlet not found for 10095 40

Ich gehe davon aus, dass dies mit meiner Proxy-Einstellung zusammenhängt. Bei Firefox wurde der Proxy-Server korrekt eingestellt. Bei Liferay habe ich (laut Documentation) die portal.properties, portal-ext.properties, system.properties und system-ext.properties erstellt, alle befindet sich im %LIFERAY-HOME%/bin - Folder. Ich habe ebenfalls den Tomcat-StartScript entsprechend modifiziert, sodass alle Dateien auch ordnungsgemäß geladen werden. Sie werden auch tatsächlich gefunden und geladen (ich habe den Tomcat-log kontrolliert). Die system-ext.properties-Datei sieht folgendermaßen aus:

http.proxyHost=**************** // mein proxyHost
http.proxyPort=**** // mein proxyPort
#http.nonProxyHosts=192.168.0.250

Dann habe ich festgestellt, dass die portal-impl.jar - Datei ebenfalls die "system-ext.properties" - Property-Datei enthält. Diese wurde ebenfalls modifiziert.

Aber es hat leider nichts geholfen. Das selbe Problem kommt bei allen meinen Portlets auf, die auf irgendwelche externe WWW-Seiten zugreifen wollen (z.B. beim Google-Portlet). Also ich gehe davon aus, dass dies (ich bin *fast* sicher) mit der Proxy-Einstellung zusammenhängt.

Danke für eure Hilfe

Mit freundlichen Grüßen

MARTIN MINTAL
Artur Linhart
RE: PlugIn Installer // Proxy ?
February 7, 2008 10:27 AM
Answer

Artur Linhart

Rank: Expert

Posts: 458

Join Date: September 13, 2007

Recent Posts

Hallo,

ist der server auf der selben Maschine wie der Client? Natuerlich ist es die servereinstellung und der Server verbindet sich zum liferay-web... Aber ich vermute es ist so und die proxy mit der gegebenen Adresse sollte vom server erreichbar sein.

Wird dort ein login Lum Proxy gebraucht? Wenn ja, ist es ein Problem... Ich vermute wird kein benutzt...

Ist nicht in dem verzeichnis webapps/ROOT/WEB-INF/classes eine Datei system-ext.properties, wo diese einstellung noch falsch ist? Ich vermute, es sollte man die Einstellung in dieser Datei reinschreiben. Eigentlich sollte man nur diese modifizieren - das Verzeichnis webapps/ROOT/WEB-INF/classes wird als erstes in dem classpath genommen und dadurch muss/sollte man nix innerhalb der Jar-dateien modifizieren...

Gruss, Archie.
Artur Linhart
RE: PlugIn Installer // Proxy ?
February 7, 2008 10:32 AM
Answer

Artur Linhart

Rank: Expert

Posts: 458

Join Date: September 13, 2007

Recent Posts

Und noch eine Bemerkung - die Meldung

14:11:00,203 WARN [PortletLocalServiceImpl:142] Portlet not found for 10095 40

hat meiner Erachtung nach mit den Verbindungsproblemen nichts zu tun. ID 40 hat das Portlet Location Admin (mindestends in der Version 4.3.5), was zeigt, dass es einfach auch ein Installationsproblem oder Datenkonsistenzproblem sein koennte... Dieses Portlet ist gleich in der Basisinstallation und deswegen sollte er immer gefunden werden auch wenn die Liferay-sites nicht erreichbar sind...

Gruss, Artur