Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Madhu Yadav
error loading repositories in startup
July 9, 2009 2:35 AM
Answer

Madhu Yadav

Rank: Regular Member

Posts: 118

Join Date: January 23, 2009

Recent Posts

has anyone come across this before? It happened after i migrate from 5.1 to 5.2
 107:41:53,780 INFO  [PluginPackageUtil:1150] Reloading repositories
 207:41:54,716 ERROR [JobWrapper:78] com.liferay.portal.kernel.job.JobExecutionException: com.liferay.portal.SystemException: java.lang.NullPointerException
 3com.liferay.portal.kernel.job.JobExecutionException: com.liferay.portal.SystemException: java.lang.NullPointerException
 4    at com.liferay.portlet.admin.job.CheckRemoteRepositoriesJob.execute(CheckRemoteRepositoriesJob.java:46)
 5    at com.liferay.portal.job.JobWrapper.execute(JobWrapper.java:66)
 6    at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
 7    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:529)
 8Caused by: com.liferay.portal.SystemException: java.lang.NullPointerException
 9    at com.liferay.portal.plugin.PluginPackageUtil._reIndex(PluginPackageUtil.java:1144)
10    at com.liferay.portal.plugin.PluginPackageUtil._reloadRepositories(PluginPackageUtil.java:1175)
11    at com.liferay.portal.plugin.PluginPackageUtil.reloadRepositories(PluginPackageUtil.java:215)
12    at com.liferay.portlet.admin.job.CheckRemoteRepositoriesJob.execute(CheckRemoteRepositoriesJob.java:43)
13    ... 3 more
14Caused by: java.lang.NullPointerException
15    at com.liferay.portal.kernel.messaging.MessageBusUtil._sendMessage(MessageBusUtil.java:175)
16    at com.liferay.portal.kernel.messaging.MessageBusUtil._sendMessage(MessageBusUtil.java:183)
17    at com.liferay.portal.kernel.messaging.MessageBusUtil.sendMessage(MessageBusUtil.java:89)
18    at com.liferay.portal.search.IndexWriterImpl.deletePortletDocuments(IndexWriterImpl.java:68)
19    at com.liferay.portal.kernel.search.SearchEngineUtil.deletePortletDocuments(SearchEngineUtil.java:69)
20    at com.liferay.portal.plugin.PluginPackageIndexer.cleanIndex(PluginPackageIndexer.java:72)
21    at com.liferay.portal.plugin.PluginPackageUtil._reIndex(PluginPackageUtil.java:1111)
22    ... 6 more
Robert Smith
RE: error loading repositories in startup
March 1, 2010 2:15 PM
Answer

Robert Smith

Rank: Junior Member

Posts: 40

Join Date: October 15, 2009

Recent Posts

I get the same error. Did you ever figure out what the problem is?
Yannick Ongena
RE: error loading repositories in startup
March 2, 2010 6:01 AM
Answer

Yannick Ongena

Rank: Junior Member

Posts: 26

Join Date: February 22, 2010

Recent Posts

isn't this because you are behind a proxy server or you are not connected to the internet so liferay can not contact the repository?
Madhu Yadav
RE: error loading repositories in startup
March 4, 2010 9:19 AM
Answer

Madhu Yadav

Rank: Regular Member

Posts: 118

Join Date: January 23, 2009

Recent Posts

no robert, i haven't checked back on it..

btw, I did have internet access in that env and which didn't require proxy settings as well..
not facing this problem in 5.2.3