Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Saroj Nayak
deploy war automatically in to the deploy folder is not working for me
December 25, 2013 11:37 PM
Answer

Saroj Nayak

Rank: New Member

Posts: 9

Join Date: May 16, 2012

Recent Posts

Hi ,

I am using liferay 6.2
After ant build portlet is build successfully but not deploying the portlet war file in to deploy folder

when I was using earlier version of liferay it was automatically deploy the war file into the deploy folder after build .


I need Help ...
Debasis Padhi
RE: deploy war automatically in to the deploy folder is not working for me
December 25, 2013 11:41 PM
Answer

Debasis Padhi

Rank: Junior Member

Posts: 55

Join Date: March 23, 2012

Recent Posts

Hi saroj,

You need to add following properties in your build.user.properties file which is inside your plugin sdk

auto.deploy.dir = ${app.server.parent.dir}/deploy
Bhagyashree Khilar
RE: deploy war automatically in to the deploy folder is not working for me
December 26, 2013 12:06 AM
Answer

Bhagyashree Khilar

Rank: New Member

Posts: 2

Join Date: December 26, 2013

Recent Posts

Hi debasis

I was also facing same problem but now it is solved after add the above property in my build.user.properties
the war file is copied into the deploy folder but tomcat doesn't pick that WAR file from deploy folder

Can you please help me ..
Debasis Padhi
RE: deploy war automatically in to the deploy folder is not working for me
December 26, 2013 12:16 AM
Answer

Debasis Padhi

Rank: Junior Member

Posts: 55

Join Date: March 23, 2012

Recent Posts

Hi khilar,

I am sure you might be changed your working server location or rename the server @LIFERAY_HOME folder

you need to check path of liferay tomcat folder, which is mention in portal-setup-wizard.properties with property liferay.home

check they both are same or not
Bhagyashree Khilar
RE: deploy war automatically in to the deploy folder is not working for me
December 26, 2013 12:28 AM
Answer

Bhagyashree Khilar

Rank: New Member

Posts: 2

Join Date: December 26, 2013

Recent Posts

thanks debasis It is working ...