Combination View Flat View Tree View
Threads [ Previous | Next ]
Carlos Bergero
change localhost:8080 to a different URL
November 8, 2013 7:48 AM

Carlos Bergero

Rank: New Member

Posts: 1

Join Date: November 8, 2013

Recent Posts

hello, as you will see I'm new in LifeRay, I just finish my first deploy and got stuck running in circles with a configuration issue, and though I have review, guides, wiki and forums I Cant figure out how to fix this problem.
The issue is as follows, like I say I just install LifeRay 6.1 liferay-portal-6.1.2-ce-ga3 particularly this build with Tomcat 7, in Centos 6.4, I manage to connect it to MySQL DB, no trouble there, mostly, and started the bundle Tomcat successfully, database was populated and working fine, and I could access the localhost:8080 to the starting page and log in with user pass test.
So far so god, now I need to change the access URL, to give access to the server to a client, I have to use NAT and redirect the input from to internalIP:8080, internaIP is the IP of the server running LifeRay, I have tested connection from the Firewall to internalIP:8080 and works fine.
The problem starts when I connect to, and log in, I open the site and log in with test user, and the site redirects me to localhost:8080
I have walk trough the configuration options and test different options in Portal Settings which seamed to be the place but had no luck changing the behaviour of LifeRay.
Any Input on the matter is more than welcome,

David H Nebinger
RE: change localhost:8080 to a different URL
November 8, 2013 7:52 AM

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 11622

Join Date: September 1, 2006

Recent Posts

8443 will also work for Liferay, Carlos. 8443 is the SSL-equivalent of the 8080 port number. Just use https://localhost:8443 and everything will work fine.
Christoph Rabel
RE: change localhost:8080 to a different URL
November 11, 2013 12:58 AM

Christoph Rabel

Rank: Regular Member

Posts: 198

Join Date: September 24, 2009

Recent Posts

The easiest way to fix your problem is to edit server.xml (tomcat/conf/server.xml).
But before you do that, 8443 is usually https. Since you didn't specify the protocol, you have two options:

Yes, I want to use https:
Simply remove the comments:
2    <!--
3    <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
4               maxThreads="150" scheme="https" secure="true"
5               clientAuth="false" sslProtocol="TLS" />
6    -->

No, I want to use http:
Replace port="8080" with port="8443" in this line:
2<Connector URIEncoding="UTF-8" connectionTimeout="20000" port="8080" protocol="HTTP/1.1" redirectPort="8443"/>