Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Jen Cooper
Cant start portal
September 17, 2013 3:40 AM
Answer

Jen Cooper

Rank: New Member

Posts: 9

Join Date: August 26, 2013

Recent Posts

I have just completed the installation process onto an existing tomcat instance on a linux based VPS. I cannot connect to the server when I point my browser to :8080, and the log file shows the following:

Sep 17, 2013 8:36:59 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/local/jdk1.6.0_26/jre/lib/amd64/server:/usr/local/jdk1.6.0_26/jre/lib/amd64:/usr/local/jdk1.6.0_26/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
Sep 17, 2013 8:37:00 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlValidation' to 'false' did not find a matching property.
Sep 17, 2013 8:37:00 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlNamespaceAware' to 'false' did not find a matching property.
Sep 17, 2013 8:37:01 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-12004"]
Sep 17, 2013 8:37:01 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 3295 ms
Sep 17, 2013 8:37:01 PM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Sep 17, 2013 8:37:01 PM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.42
Sep 17, 2013 8:37:01 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-12004"]
Sep 17, 2013 8:37:01 PM org.apache.catalina.connector.MapperListener findDefaultHost
WARNING: Unknown default host for connector [Connector[HTTP/1.1-12004]]
Sep 17, 2013 8:37:01 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 137 ms


Any advice?
David H Nebinger
RE: Cant start portal
September 17, 2013 5:38 AM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 11770

Join Date: September 1, 2006

Recent Posts

Yep, I'm guessing you have an environment variable defined for CATALINA_HOME that does not point to where your liferay bundle was deployed.