Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Koen De Jaeger
Marketplace for CE 6.1.2
September 4, 2013 7:00 AM
Answer

Koen De Jaeger

Rank: New Member

Posts: 13

Join Date: September 14, 2010

Recent Posts

Hello,

The current war file give an error : "... does not support this version of Liferay".
Is the MP going to be updated?
What's the plan?
James Falkner
RE: Marketplace for CE 6.1.2
September 4, 2013 7:06 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Koen De Jaeger:
Hello,

The current war file give an error : "... does not support this version of Liferay".
Is the MP going to be updated?
What's the plan?


Will get this updated ASAP. We've been going through and updating all the plugins for 6.1.2 GA3. Thanks for the report!
Koen De Jaeger
RE: Marketplace for CE 6.1.2
September 13, 2013 6:48 AM
Answer

Koen De Jaeger

Rank: New Member

Posts: 13

Join Date: September 14, 2010

Recent Posts

IIt's available for download now but it's missing a dependency that's not available for download.

Do we have to compile portlet 'portal-compat-hook' ourselves?
James Falkner
RE: Marketplace for CE 6.1.2
September 13, 2013 9:17 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Koen De Jaeger:
IIt's available for download now but it's missing a dependency that's not available for download.

Do we have to compile portlet 'portal-compat-hook' ourselves?


portal-compat-hook is included in the Liferay bundles you can download, so you should already have it, if using bundles. If not, then yeah you'll have to compile it yourself emoticon I'll see if we can get it to be part of the plugin itself. I think it may need to be on the Marketplace itself (the hook). It's a new thing in GA3 so I'll get some more information and get back to you.
James Falkner
RE: Marketplace for CE 6.1.2
September 13, 2013 9:39 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

James Falkner:
Koen De Jaeger:
IIt's available for download now but it's missing a dependency that's not available for download.

Do we have to compile portlet 'portal-compat-hook' ourselves?


portal-compat-hook is included in the Liferay bundles you can download, so you should already have it, if using bundles. If not, then yeah you'll have to compile it yourself emoticon I'll see if we can get it to be part of the plugin itself. I think it may need to be on the Marketplace itself (the hook). It's a new thing in GA3 so I'll get some more information and get back to you.


BTW, I put a temporary copy of the compiled portal-compat-hook here. It's on our FTP server which is periodically wiped out, we are looking for a permanent home now, but this may help you in the short term!
Koen De Jaeger
RE: Marketplace for CE 6.1.2
September 14, 2013 9:20 AM
Answer

Koen De Jaeger

Rank: New Member

Posts: 13

Join Date: September 14, 2010

Recent Posts

Tnx. That worked.

I upgraded from 6.1.1so good to have a war file for this.
Leonardo Costanitni
RE: Marketplace for CE 6.1.2
January 3, 2014 2:41 PM
Answer

Leonardo Costanitni

Rank: New Member

Posts: 1

Join Date: October 27, 2010

Recent Posts

James Falkner:
James Falkner:
Koen De Jaeger:
IIt's available for download now but it's missing a dependency that's not available for download.

Do we have to compile portlet 'portal-compat-hook' ourselves?


portal-compat-hook is included in the Liferay bundles you can download, so you should already have it, if using bundles. If not, then yeah you'll have to compile it yourself emoticon I'll see if we can get it to be part of the plugin itself. I think it may need to be on the Marketplace itself (the hook). It's a new thing in GA3 so I'll get some more information and get back to you.


BTW, I put a temporary copy of the compiled portal-compat-hook here. It's on our FTP server which is periodically wiped out, we are looking for a permanent home now, but this may help you in the short term!

Hi James,
I'm in the very same situation as Koen...
I downloaded the marketplace war from liferay'site, but it cast a dependency error (i.e portal-compat-hook...)
thus two question:
is it possible to let this available for download somewhere (please ... emoticon )?

why this happens?
I mean: the marketplace war is for download, but it fails on a dependency that is not for download...
Could it be possible to "trivially" substitute the marketplace war in the marketplace download link with a zip file with all the needed wars inside (marketplace, portal-compat-hook,...)?
IMHO this could be fast and effective...

Best Regards,
Leonardo