Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Sophia Cui
Disable OpenId Authentication?
April 9, 2009 8:51 AM
Answer

Sophia Cui

Rank: Regular Member

Posts: 119

Join Date: August 14, 2008

Recent Posts

I do not want the link for OpenID authentication show in the Sign In portlet, so in portal-ext properties file, I set:

open.id.auth.enabled=false

But it is still there? Could anybody help me with this?

Liferay 5.2.2 with Tomcat 6.0.18


Sophia
Nico Ekito
RE: Disable OpenId Authentication?
April 10, 2009 7:37 AM
Answer

Nico Ekito

Rank: Regular Member

Posts: 163

Join Date: October 7, 2008

Recent Posts

Strange, it works for me (same Liferay and Tmcat versions).

Did you place your properties file in the correct place ?
1<tomcat home>/webapps/ROOT/WEB-INF/classes/portal-ext.properties
Sophia Cui
RE: Disable OpenId Authentication?
April 13, 2009 12:17 PM
Answer

Sophia Cui

Rank: Regular Member

Posts: 119

Join Date: August 14, 2008

Recent Posts

Nico Ekito:
Strange, it works for me (same Liferay and Tmcat versions).

Did you place your properties file in the correct place ?
1<tomcat home>/webapps/ROOT/WEB-INF/classes/portal-ext.properties


Just double checked, that's where I put it.

My database is MS SQL, will that make difference?

Werid!

Sophia
Amos Fong
RE: Disable OpenId Authentication?
April 13, 2009 12:40 PM
Answer

Amos Fong

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1913

Join Date: October 7, 2008

Recent Posts

Hey Sophia,

You probably made some change to the settings category in control panel. The value in portal.properties will be overridden by any changes in the admin interface if it exists. Go to control panel > settings > authentication and turn off open ID from there.
Sophia Cui
RE: Disable OpenId Authentication?
April 13, 2009 1:13 PM
Answer

Sophia Cui

Rank: Regular Member

Posts: 119

Join Date: August 14, 2008

Recent Posts

Amos Fong:
Hey Sophia,

You probably made some change to the settings category in control panel. The value in portal.properties will be overridden by any changes in the admin interface if it exists. Go to control panel > settings > authentication and turn off open ID from there.


Ok, now it is working!
Thank you so much!

Sophia
Linus Sphinx
RE: Disable OpenId Authentication?
February 25, 2011 12:07 PM
Answer

Linus Sphinx

Rank: Junior Member

Posts: 89

Join Date: August 12, 2010

Recent Posts

I believe he is quite correct, open.id.auth.enabled=false for me has no effect, this can only be turned off in the control panel.

Was in error here, find the control panel row in portal_preferences and replace the xml doc with a empty tag and it follows the properties just fine.
Rafique Nazir
RE: Disable OpenId Authentication?
December 1, 2013 10:01 PM
Answer

Rafique Nazir

Rank: New Member

Posts: 1

Join Date: December 1, 2013

Recent Posts

Following links shown on Login Page can be removed from Control Panel:
1. OpenID
Go to Control Panel-->Portal Settings-->Authentication-->OpenID Tab
-And uncheck Enabled
-And save changes
2. Create Account
Go to Control Panel-->Portal Settings-->Authentication-->General Tab
And uncheck
-Allow strangers to create accounts?
-Allow strangers to create accounts with a company email address?
And save changes
3. Forgot Password
Go to Control Panel-->Portal Settings-->Authentication-->General Tab
And uncheck
-Allow users to request forgotten passwords?
-Allow users to request password reset links?
And save changes