Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Luis Silva
Error importing LDAP users 6.1.1 (group issue?)
April 26, 2013 9:19 AM
Answer

Luis Silva

Rank: Junior Member

Posts: 42

Join Date: April 18, 2013

Recent Posts

Hi,
I'm trying to import accounts from my company AD, but i'm having problems.
The import is giving
ERROR [liferay/scheduler_dispatch-2][PortalLDAPImporterImpl:698] Unable to import user cn=xxxx: null:null:{cn=cn: xxxx}
java.lang.NullPointerException

In the Connection, I make the Test LDAP Connection and is ok
In Users I test and I can see some of the AD users (also if I make some mappings they work, so there is no AD connection problem)
In groups perhaps is my problem, the AD don't have any. (I also don't have admin access to AD).

If I don't have any Group the import fail's?
I try to workaround this, I read that there is a option to put in portal-ext.properties the field ldap.import.method=user, this only gets users right?
But its not working for me.
Since I diden't had the file I put it in \Liferay\tomcat-7.0.27\webapps\ROOT\WEB-INF\classe
It's the only field in the file, should instead put the field on the DB? And where...

Any help, thanks

Regards
Lsilva
Konstantin Chudinov
RE: Error importing LDAP users 6.1.1 (group issue?)
June 27, 2013 9:42 AM
Answer

Konstantin Chudinov

Rank: Junior Member

Posts: 43

Join Date: April 23, 2013

Recent Posts

Hi!
I have the same problem. Have you solved it?
Ankit Srivastava
RE: Error importing LDAP users 6.1.1 (group issue?)
June 29, 2013 12:23 AM
Answer

Ankit Srivastava

Rank: Regular Member

Posts: 197

Join Date: April 15, 2011

Recent Posts

Hi Luis,

Can you check your AD that all attributes required are available there or not, for example cn, sn etc?

It seems that your authentication is working but user importing is not working.

User Import work in two ways : User or Group, You are using user import so there is no issue when you dont have any group defined in your AD.

Thanks:
Tonu
Luis Silva
RE: Error importing LDAP users 6.1.1 (group issue?)
July 1, 2013 4:54 AM
Answer

Luis Silva

Rank: Junior Member

Posts: 42

Join Date: April 18, 2013

Recent Posts

Hi,
No I dident solved it. I give up importing users.

Regard's
Luis Silva
Ranga Rao Bobbili
RE: Error importing LDAP users 6.1.1 (group issue?)
July 2, 2013 5:11 PM
Answer

Ranga Rao Bobbili

Rank: Regular Member

Posts: 152

Join Date: July 20, 2007

Recent Posts

Hi All,

I was also experienced same issue. After long analysis, i realized and resolved my issue by assign user to one group.

As per my analysis if we want to import user from LDAP, user should belong to at least one group.

Thanks & Regards,
Ranga Rao Bobbili