Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Pawal Adhikari
Password Placeholder not working on Firefox while using <aui:form>
April 12, 2013 1:09 AM
Answer

Pawal Adhikari

Rank: New Member

Posts: 18

Join Date: March 6, 2013

Recent Posts

I have encountered a strange problem while using placeholder. Password Placeholder works just fine in chrome but in firefox it shows '*****' instead of intended plain text which i used in placeholder.

1   <aui:input placeholder="Password" name="password" showRequiredLabel="<%= false %>" type="password" autocomplete="off"/>


Strange thing is firefox do support placeholder and when used outside of <aui:form> it's working just fine. Moreover, when used in simple html form tag it's working fine.

What am i doing wrong? I just don't want to switch to simple html form as i am using aui validation.

Moreover, at first dot appears in the password field of same length as placeholder but when it is clicked the placeholder appears.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
April 12, 2013 2:00 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

Hi Pawan ,
Which version Firefox you are using ?
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
April 12, 2013 2:51 AM
Answer

Pawal Adhikari

Rank: New Member

Posts: 18

Join Date: March 6, 2013

Recent Posts

18.0.1 and i am pretty sure that it is compatible, http://caniuse.com/input-placeholder . And, i just found that it's not only password placeholder issue but too of text field.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
April 12, 2013 4:11 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

hi,
I tested your code its working fine on my Firefox browser and i am using Ver 21.0 !!
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
April 12, 2013 6:35 PM
Answer

Pawal Adhikari

Rank: New Member

Posts: 18

Join Date: March 6, 2013

Recent Posts

hi,
It's working just fine in firefox but issue appears when i use it inside <aui:form>.
Using outside of form or in simple html form doesn't show any problem.
Raffael Tregilgas
RE: Password Placeholder not working on Firefox while using <aui:form>
April 22, 2013 7:56 AM
Answer

Raffael Tregilgas

Rank: New Member

Posts: 7

Join Date: April 23, 2012

Recent Posts

hi
did you have any luck finding a solution for this problem? have the same thing in ff 20.0.1 and its not working
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
May 8, 2013 2:32 AM
Answer

Pawal Adhikari

Rank: New Member

Posts: 18

Join Date: March 6, 2013

Recent Posts

nope