Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
gary b
deploy process hangs
March 8, 2013 2:46 AM
Answer

gary b

Rank: Junior Member

Posts: 75

Join Date: February 2, 2013

Recent Posts

I am deploying the portlet on local and deploy process hangs here:

 110:25:48,716 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:177] Processing InvestorSignUp-portlet-6.1.1.1.war
 210:25:48,717 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][PortletAutoDeployListener:77] Copying portlets for F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war
 310:25:48,718 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:763] Deploying InvestorSignUp-portlet-6.1.1.1.war
 410:25:48,748 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:859] Updating InvestorSignUp from version 6.1.1.1 to version 6.1.1.1
 5  Expanding: F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war into F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748
 6  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF
 7  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\classes
 8  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\classes
 9  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\jsp
1010:25:49,028 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2083] Modifying Servlet 2.4 F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\web.xml
11  Copying 206 files to F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
12  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
13  Deleting directory F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748
1410:25:49,574 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][PortletAutoDeployListener:87] Portlets for F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war copied successfully. Deployment will start in a few seconds.
158 Mar, 2013 10:25:51 AM org.apache.catalina.startup.HostConfig checkResources
16INFO: Undeploying context [/InvestorSignUp-portlet]
1710:25:51,604 INFO  [ContainerBackgroundProcessor[StandardEngine[Catalina]]][PluginPackageUtil:1033] Reading plugin package for InvestorSignUp-portlet
188 Mar, 2013 10:25:51 AM org.apache.catalina.core.ApplicationContext log
19INFO: Closing Spring root WebApplicationContext
208 Mar, 2013 10:25:52 AM org.apache.catalina.startup.HostConfig deployDirectory
21INFO: Deploying web application directory F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
2210:25:52,505 INFO  [pool-2-thread-5][HotDeployImpl:178] Deploying InvestorSignUp-portlet from queue
2310:25:52,505 INFO  [pool-2-thread-5][PluginPackageUtil:1033] Reading plugin package for InvestorSignUp-portlet
24Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties
25Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
26Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties
27Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
288 Mar, 2013 10:25:52 AM org.apache.catalina.core.ApplicationContext log
29INFO: Initializing Spring root WebApplicationContext
30Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
31Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties

Portlet is working properly and even not giving any error but still not showing 1 portlet is available for use
And when I am deploying the war on production... deploy process hangs on same place and not able to drag the portlet on page.


I am using liferay-6.1.1-ce-ga2.
Please help...
Dipanjan Das
RE: deploy process hangs
March 8, 2013 2:00 PM
Answer

Dipanjan Das

Rank: Junior Member

Posts: 30

Join Date: September 28, 2012

Recent Posts

You could increase the max perm-size in startup.bat of tomcat to resolve this issue.
Jitendra Rajput
RE: deploy process hangs
March 9, 2013 7:19 AM
Answer

Jitendra Rajput

Rank: Liferay Master

Posts: 858

Join Date: January 7, 2011

Recent Posts

Basically the log level for deployer located in com.liferay.portal.deploy.hot package are default set to ERROR level. To get your successful deployment message just modify the log level the com.liferay.portal.deploy.hot.*HotDeployListener loggers.


Above changes will be lost if you restart your server so if you want permanent solution then override portal-log4j.xml in your ext - plugin and change below entries.
Set log level to info instead of error.

1<category name="com.liferay.portal.deploy.hot.PortletHotDeployListener">
2        <priority value="INFO" />
3  </category>
Hitoshi Ozawa
RE: deploy process hangs
March 9, 2013 11:36 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Is this a custom portlet or a portlet from liferay's Marketplace?
gary b
RE: deploy process hangs
March 10, 2013 10:39 PM
Answer

gary b

Rank: Junior Member

Posts: 75

Join Date: February 2, 2013

Recent Posts

Hitoshi Ozawa:
Is this a custom portlet or a portlet from liferay's Marketplace?


It 's a custom portlet.
Hitoshi Ozawa
RE: deploy process hangs
March 11, 2013 4:38 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

If your custom portlet is hanging, it only means you have a bug in your custom portlet. I don't think anyone can say what's wrong with your portlet because we don't know your portlet.
gary b
RE: deploy process hangs
March 13, 2013 4:36 AM
Answer

gary b

Rank: Junior Member

Posts: 75

Join Date: February 2, 2013

Recent Posts

Hitoshi Ozawa:
If your custom portlet is hanging, it only means you have a bug in your custom portlet. I don't think anyone can say what's wrong with your portlet because we don't know your portlet.



Actually this is not happening only with one portlet but with all custom portlets.
Jitendra Rajput
RE: deploy process hangs
March 13, 2013 5:08 AM
Answer

Jitendra Rajput

Rank: Liferay Master

Posts: 858

Join Date: January 7, 2011

Recent Posts

Did you tried by changing log levels from control panel ?
dave ch
RE: deploy process hangs
March 13, 2013 7:01 AM
Answer

dave ch

Rank: Regular Member

Posts: 164

Join Date: February 6, 2012

Recent Posts

Is this a custom portlet or a portlet from liferay's Marketplace?


I am customizing liferay's Marketplace portlets and getting the same result after deploy, i.e, not getting "portlet is available for use ".
But the portlet is getting deployed and working fine and not giving any error.
What would be the possible reason for this?

Dave
dave ch
RE: deploy process hangs
March 13, 2013 7:08 AM
Answer

dave ch

Rank: Regular Member

Posts: 164

Join Date: February 6, 2012

Recent Posts

Did you tried by changing log levels from control panel ?


Changing log levels solves my issue.

Thanks.
Jitendra Rajput
RE: deploy process hangs
March 13, 2013 7:22 AM
Answer

Jitendra Rajput

Rank: Liferay Master

Posts: 858

Join Date: January 7, 2011

Recent Posts

Make sure you modify the same in portal-log4j-ext.xml also other wise log setting will be lost next time when you restart your server.
gary b
RE: deploy process hangs
March 13, 2013 10:34 PM
Answer

gary b

Rank: Junior Member

Posts: 75

Join Date: February 2, 2013

Recent Posts

Jitendra Rajput:
Make sure you modify the same in portal-log4j-ext.xml also other wise log setting will be lost next time when you restart your server.



Thanks Jitendra,

Changing log levels solves the issue .Sorry for replying late :-)