Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Kevin S Neibarger
LifeRay 5.2.1, Websphere 6.1 and Custom Themes
February 12, 2009 6:48 AM
Answer

Kevin S Neibarger

Rank: New Member

Posts: 5

Join Date: February 11, 2009

Recent Posts

Hello - I currently have LifeRay portal version 5.2.1 installed on Websphere 6.1 and I want to apply a custom theme that I created in version 5.1.2 on tomcat. How do I do this? Is there a simple way like there was via tomcat and the plugin installer?

I even tried to download a theme from my local was server within the portal and it didn't work.

From the communities portlet --> community --> manage pages --> look and feel I selected "Install More" from the Available Themes and selected the "nautica-05-theme". When I go to my log, I see this:

[2/12/09 9:43:28:989 EST] 00000042 SystemOut O 09:43:28,974 INFO [AutoDeployDir:183] Processing nautica-05-theme-5.2.0.1.war
[2/12/09 9:43:29:021 EST] 00000042 SystemOut O 09:43:29,005 INFO [ThemeAutoDeployListener:54] Copying themes for C:\WINDOWS\system32\config\systemprofile\liferay\deploy\nautica-05-theme-5.2.0.1.war
[2/12/09 9:43:29:114 EST] 00000042 SystemOut O Expanding: C:\WINDOWS\system32\config\systemprofile\liferay\deploy\nautica-05-theme-5.2.0.1.war into C:\WINDOWS\TEMP\20090212094329036
[2/12/09 9:43:29:864 EST] 00000042 SystemOut O Copying 1 file to C:\WINDOWS\TEMP\20090212094329036\WEB-INF
[2/12/09 9:43:30:380 EST] 00000042 SystemOut O Copying 1 file to C:\WINDOWS\TEMP\20090212094329036\WEB-INF\classes
[2/12/09 9:43:30:396 EST] 00000042 SystemOut O Copying 1 file to C:\WINDOWS\TEMP\20090212094329036\WEB-INF\classes
[2/12/09 9:43:30:458 EST] 00000042 SystemOut O Copying 1 file to C:\WINDOWS\TEMP\20090212094329036\WEB-INF
[2/12/09 9:43:30:849 EST] 00000042 SystemOut O Building war: C:\WINDOWS\TEMP\20090212094330724
[2/12/09 9:43:31:240 EST] 00000042 SystemOut O Building war: c:\Program Files\IBM\WebSphere\AppServer\profiles\LimitedStores\..\webapps\nautica-05-theme.war
[2/12/09 9:43:31:255 EST] 00000042 SystemOut O 09:43:31,255 INFO [ThemeAutoDeployListener:60] Themes for C:\WINDOWS\system32\config\systemprofile\liferay\deploy\nautica-05-theme-5.2.0.1.war copied successfully. Deployment will start in a few seconds.


And it just hangs, and never really deploys anything. Any ideas why?
Saranga Pani Rao
RE: LifeRay 5.2.1, Websphere 6.1 and Custom Themes
February 12, 2009 9:14 PM
Answer

Saranga Pani Rao

Rank: Junior Member

Posts: 34

Join Date: February 7, 2009

Recent Posts

Hi ,

I Can deploy the Theme in the Web-Sphere6 here is the steps that you should flow
the theme i am using is envision-theme-5.2.0.1 and added web.xml file .

I am not able to see the theme of enivison..................

Theme installation
Under WAS the LR portlet for plugin installation doesn’t work. The way to make a theme visible is the following.
3.1.1 Install theme
Within the WAS console:
• Applications-- > Enterprise Applications
• Check liferay-portal-X.X.X.war row and click on update (the application has to be stopped now).
• Choose the radio box “Replace or add a single module” and fill the form:
• A name for the theme in the first text field
• The path of the WAR of the theme.
• The context root of the theme: this must be equal to the <display-name> value in web.xml. In case the context root is already used by another module, <display-name> has to be changed to be equal to the chosen context root for the theme.
• Go to the end of the wizard, press finish and Save.
To prevent an error during WAR upload from WAS console, with LR 5.0.1 it is necessary to add an empty web.xml to the theme’s war, in the WEB-INF/ dir:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
</web-app>


Do you have any idea on this ...? Please let me know ....

Regards,
Saranga
Hervé Ménage
RE: LifeRay 5.2.1, Websphere 6.1 and Custom Themes
March 10, 2009 8:38 AM
Answer

Hervé Ménage

Rank: Junior Member

Posts: 50

Join Date: March 1, 2007

Recent Posts

Hello,

Have you successfully deployed a Liferay 5.2.2 theme on WAS 6.1 ?

I deployed an EAR, which contains:
- Liferay 5.2.2, context root "/portal"
- my-theme, context root equals to display name "my-theme"

Liferay is working very well, but I cannot see my theme in the theme plugin section.
How does Liferay registers deployed themes when these are not deployed through Liferay UI?

Thank you for your help
Hervé
Herve Costa Ferreira
RE: LifeRay 5.2.1, Websphere 6.1 and Custom Themes
July 9, 2009 9:10 AM
Answer

Herve Costa Ferreira

Rank: New Member

Posts: 9

Join Date: June 25, 2009

Recent Posts

Hi,

In using Liferay 5.2.3 over WebSphere 7.0. And it's working ~fine.

Are you able to install new Portlet applications using the Control Panel in the liferay?

Thanks in Advance