Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Satish Avhad
Cannot deploy portlets on WebSphere-AIX
February 14, 2013 4:30 AM
Answer

Satish Avhad

Rank: New Member

Posts: 4

Join Date: March 29, 2011

Recent Posts

Hi;


I am using WAS 8.5 and tried deploying portlets to liferay-portal-6.1.20 ee ga2 and liferay-portal-6.1.1 ce ga2 but with same result given at bottom.
I am trying to deploy simple hello-world portlets on WebSphere using WAS console based on instructions given on other threads. I am able to deploy them on tomcat but when i try to do the same using Admin Console of WAS by updating liferay application and choosing (Replace or add a single file). I am getting following error message shown below . any pointers?




 1ADMA5064I: FileMergeTask completed successfully for liferay-portal-6_1_20-ee-ga2-20120731110418084_war.
 2
 3ADMA5006E: An error occurred configuring liferay-portal-6_1_20-ee-ga2-20120731110418084_war in WebSphere Application Server repository: java.lang.StringIndexOutOfBoundsException
 4
 5ADMA0185W: An update application operation failed and the configuration session could not be restored to its state before the operation was initiated. The configuration session is in an inconsistent state, and changes made in the session should be discarded.
 6
 7ADMA5011I: The cleanup of the temp directory for application liferay-portal-6_1_20-ee-ga2-20120731110418084_war is complete.
 8
 9ADMA5080E: Update of liferay-portal-6_1_20-ee-ga2-20120731110418084_war has ended. The update failed.
10
11Update of liferay-portal-6_1_20-ee-ga2-20120731110418084_war has ended. The update failed.


I tried auto deploy but liferay calls wsadmin.bat instead of wsadmin.sh
Rafael Lluis
RE: Cannot deploy portlets on WebSphere-AIX
January 8, 2016 2:26 AM
Answer

Rafael Lluis

Rank: Junior Member

Posts: 30

Join Date: October 15, 2012

Recent Posts

Same exactly bug here with:

Liferay 6.2 GA 5
Websphere 8.5.5 with last fixpack of December 11th 2015 (8.5.5.8)

When we deploy a portlet we have StringIndexOutOfBounds Exception on the console

Anyone can help? Thank you in advance
David H Nebinger
RE: Cannot deploy portlets on WebSphere-AIX
January 8, 2016 6:25 PM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 11064

Join Date: September 1, 2006

Recent Posts

You may find that you need to use the "direct deploy" build target for your plugins and deploy them via the websphere console rather than Liferay auto deploy.