Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Neetu Chopra
Liferay doesn't start still.
January 30, 2013 8:51 PM
Answer

Neetu Chopra

Rank: New Member

Posts: 3

Join Date: January 29, 2013

Recent Posts

Hi,

I am working on centos 6.2.
I installed Liferay as per this link:
http://www.bluhm-de.com/installing-liferay-6.1.1-on-centos-6.2

Further I have used all commands mentioned in the thread below but Liferay does not start automatically after boot:
http://www.liferay.com/community/forums/-/message_boards/message/8255964

Please help.

This server will be soon used for production purposes.

Regards,
Neetu Chopra
Hitoshi Ozawa
RE: Liferay doesn't start still.
January 31, 2013 2:34 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Liferay 6.1.1 requires Oracle JDK 1.6. JDK1.7 is planned to be supported in the next version but not in Liferay 6.1.1.

Also, the next time you post, please post the error message you are getting.
Neetu Chopra
RE: Liferay doesn't start still.
January 31, 2013 9:01 PM
Answer

Neetu Chopra

Rank: New Member

Posts: 3

Join Date: January 29, 2013

Recent Posts

Hii,

Yes that was already realised by me and corrected.JDK 1.6 is currently installed on centos VM.

May be I wasn't clear in describing my query.

The liferay is working perfectly when I start it manually (cd liferay/tomcat/bin/ and then ./startup.sh).
But I want it to start automatically if a reboot is performed.

How to do this?

I created a script name lportal in /etc/init.d as described in the link:
http://www.liferay.com/community/forums/-/message_boards/message/8255964

Also added two comment lines to make it work.

But still no success. emoticon

Any suggestions what could I have done wrong?

Regards,
Neetu Chopra
Neetu Chopra
RE: Liferay doesn't start still.
February 11, 2013 11:34 PM
Answer

Neetu Chopra

Rank: New Member

Posts: 3

Join Date: January 29, 2013

Recent Posts

Any suggestions would be highly appreciated. emoticon
Hitoshi Ozawa
RE: Liferay doesn't start still.
February 12, 2013 12:54 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

You haven't mentioned which application server you're using.
Anyways, this probably really isn't a question on getting liferay to start as a service but rather a question on getting the application server you're using to start as a service.

Check you application server's log to see if you have any directory permission errors. If not, better ask your question at the application server forum on setting up your application server as a service.

Liferay starts/stops OK on my CentOS VM as a service so it's not a problem with liferay.