Combination View Flat View Tree View
Threads [ Previous | Next ]
Omar El Tabari
liferay 6.1-CE on AIX 5.3 fails - ClassNotFound IBMJCE
January 29, 2013 2:22 AM

Omar El Tabari

Rank: New Member

Posts: 1

Join Date: January 29, 2013

Recent Posts


I am trying to install the Liferay Portal 6.1 on our AIX 5.3 server, I am using the liferay-jboss bundle because we'd like to be able to use jboss 7 and this bundle comes with jboss-7.1.1.
The problem I am getting after trying to start the server using
1jboss-7.1.1/bin/ -b
is that the portal can not load the "welcome-theme", nor the "marketplace-portlet", and then fails miserably with:
1ERROR [MSC service thread 1-1][PortalInstances:375] com.liferay.portal.kernel.exception.SystemException: com.liferay.util.EncryptorException: java.lang.ClassNotFoundException:

I have installed IBM JDK 1.6 which is needed for jboss7, here is the version output:
1Java(TM) SE Runtime Environment (build pap3260sr12-20121025_01(SR12))
2IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc-32 jvmap3260sr12-20121024_126067 (JIT enabled, AOT enabled)

I have tried both with 32-bit Java and 64-bit Java. On the same server with the same Java version I can run the Liferay portal v6.0 and a stand alone version of Jboss 7.1.1 without problems, but what I'd like to do is run the liferay-jboss 6.1 bundle, which sadly I cant

If anyone has any ideas on how to solve this problem I would be very grateful.

I can provide the full server log if needed.
And also I checked the file under "/etc/java6/jre/lib/security/" and it does have the "" provider added, I changed its priority to be at number 1 instead of the default 2.