Forums

Home » Liferay Portal » Deutsch

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Martin Fister
Anpassung default-private-page - Rollen-problem seit Liferay 4.3.x !?
October 15, 2007 9:17 AM
Answer

Martin Fister

Rank: New Member

Posts: 6

Join Date: August 15, 2006

Recent Posts

Hallo Zusammen,

seit liferay 4.3.x habe ich bei der Anpassung der Default-Ansicht (layout + portlets) des privaten Bereichs der"power user" das Problem, dass jene Portlets welche nicht im Bundle-Packet out-of-the-box dabei sind, eine die Fehlermeldung anzeigen das dem User notwendige Rolle-Zuweisungen fehlen.

"You do not have the roles required to access this portlet."


Das tritt auch bei den von Liferay bereitgestellten Google-Portlets auf, welche seit 4.3.x nicht mehr im Bundle integriert sind, sondern nachträglich manuell deployed werden müssen.

Folgende portlet-ext.properties Anpassungen habe ich vorgenommen

default.user.layout.name=Home

#
# Set the layout template id that matches an existing TPL.
#
#default.user.layout.template.id=1_2_1_columns
#default.user.layout.template.id=1_column
#default.user.layout.template.id=2_2_columns
#default.user.layout.template.id=2_columns_i
default.user.layout.template.id=2_columns_ii
#default.user.layout.template.id=2_columns_iii
#default.user.layout.template.id=3_columns

#
# Set the layout ids for the column specified in the layout template.
#
default.user.layout.column-1=google_search_portlet_WAR_google-search-portlet,71_INSTANCE_OY0d,82,23,61,65,
default.user.layout.column-2=11,29,8,19,


Also die Standardeinstellungen nur um das google-search-portlet erweitert.

Innerhalb des Google-Portlet erscheint die Fehlermeldung. Sowie in allen anderen Portlets welche manuell deployed werden.

Das Kuriose ist nur, dass man auf der gleichen Seite das google-search-portlet manuell einbinden kann und dieses ohne Meckern funktioniert.

Kennt jemand das Problem? bzw. eine Lösung ;)


Viele Grüße

Martin

PS Link zum engl. Post:
http://www.liferay.com/web/guest/community/forums/message_boards/message/200450
Martin Fister
RE: Anpassung default-private-page - Rollen-problem seit Liferay 4.3.x !?
November 13, 2007 8:34 AM
Answer

Martin Fister

Rank: New Member

Posts: 1

Join Date: October 15, 2007

Recent Posts

Mit Hilfe aus Cottbus emoticon hat sich das Problem lösen lassen.

Die Adressierung der Portlets hat sich natürlich ggü. den frühreren Versionen geändert.

Einfach den Link des Portles z.B für die EDIT-Status anschauen und schon wird klar wie das Portlet addressiert werden muss.

Viele Grüße

Martin