Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Manish Kumar
Custom portlet is not embedding in custom layout
January 8, 2013 6:18 AM
Answer

Manish Kumar

Rank: Junior Member

Posts: 94

Join Date: March 1, 2012

Recent Posts

Hello everyone,
I am using Liferay 6.1.1 EE GA2 . I have created a custom Layout of 2 rows, 3-1 column. I am embedding custom portlet in that layout, but the instead on custom portlet its code is generated on the output layout's block.

my layout's DashboardLayout.tpl is
 1<div class="columns-3" id="main-content">
 2    <table class="portlet-layout" border="2">
 3        <tr>
 4            <td class="aui-w33 portlet-column portlet-column-first" id="column-1">
 5            $processor.processPortlet("new1_WAR_testportlet")
 6                $processor.processColumn("column-1", "portlet-column-content portlet-column-content-first")
 7            </td>
 8            <td class="aui-w33 portlet-column" id="column-2">
 9            $processor.processPortlet("new2_WAR_testportlet")
10                $processor.processColumn("column-2", "portlet-column-content")
11            </td>
12            <td class="aui-w33 portlet-column portlet-column-last" id="column-3">
13            $processor.processPortlet("    new3_WAR_testportlet")
14                $processor.processColumn("column-3", "portlet-column-content portlet-column-content-last")
15            </td>
16        </tr>
17        <tr>
18            <td class="aui-w33 portlet-column" colspan="3" id="column-4">
19            $processor.processPortlet("new4_WAR_testportlet")
20                $processor.processColumn("column-2", "portlet-column-content")
21            </td>
22        </tr>
23    </table>
24</div>


and Layout's DashboardLayout.wap.tpl is
 1<div class="columns-3" id="main-content">
 2<table class="portlet-layout">
 3        <tr>
 4            <td class="aui-w33 portlet-column portlet-column-first" id="column-1">
 5                $processor.processColumn("column-1", "portlet-column-content portlet-column-content-first")
 6            </td>
 7            <td class="aui-w33 portlet-column" id="column-2">
 8                $processor.processColumn("column-2", "portlet-column-content")
 9            </td>
10            <td class="aui-w33 portlet-column portlet-column-last" id="column-3">
11                $processor.processColumn("column-3", "portlet-column-content portlet-column-content-last")
12            </td>
13        </tr>
14        <tr>
15            <td class="aui-w33 portlet-column" colspan="3" id="column-4">
16                $processor.processColumn("column-4", "portlet-column-content")
17            </td>
18        </tr>
19    </table>
20</div>


I am attaching snap shot of the output which i am getting.
Please suggest me the correction needed here to get the custom portlet in the layout's block.
Attachments: layout.bmp (1,141.6k)
Manish Kumar
RE: Custom portlet is not embedding in custom layout
January 9, 2013 3:08 AM
Answer

Manish Kumar

Rank: Junior Member

Posts: 94

Join Date: March 1, 2012

Recent Posts

Please can any one suggest me the solution.