Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Aaron Paxson
Why doesn't Knowledgebase portlet deploy??
December 16, 2012 11:28 AM
Answer

Aaron Paxson

Rank: Regular Member

Posts: 103

Join Date: July 27, 2010

Recent Posts

Hi All. I recently upgraded from LR CE 6.1.0 GA1 to LR CE 6.1.1 GA2.

Since then, I lost my knowledge-base portlet. i've tried re-installing it, but it won't install. So, thinking something happened to it, I downloaded it again from:

http://iweb.dl.sourceforge.net/project/lportal/Liferay%20Plugins/6.1.0%20GA1/knowledge-base-portlet-6.1.0.1-ce-ga1-20120106155615760.war

During the install, I'm getting this error "Failed to process TLD" and java.net.MalformedURLException. Can anyone give me any ideas? It doesn't seem like anyone else is talking about it, so I'm hesitant to put in a bug.

Thanks.

 1
 2INFO: Deploying web application archive /opt/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/webapps/knowledge-base-portlet.war
 3Dec 16, 2012 7:09:08 PM org.apache.catalina.startup.TldConfig tldScanWebXml
 4WARNING: Failed to process TLD with path [http://java.sun.com/jsp/jstl/core] and URI [/WEB-INF/tld/c.tld]
 5java.net.MalformedURLException
 6        at java.net.URL.<init>(URL.java:601)
 7        at java.net.URL.<init>(URL.java:464)
 8        at java.net.URL.<init>(URL.java:413)
 9        at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:650)
10        at com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(XMLVersionDetector.java:186)
11        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:772)
12        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
13        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
14        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
15        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
16        at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1537)
17        at org.apache.catalina.startup.TldConfig.tldScanStream(TldConfig.java:515)
18        at org.apache.catalina.startup.TldConfig.tldScanWebXml(TldConfig.java:328)
19        at org.apache.catalina.startup.TldConfig.execute(TldConfig.java:243)
20        at org.apache.catalina.startup.TldConfig.lifecycleEvent(TldConfig.java:540)
21        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
22        at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
23        at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5161)
24        at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
25        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:895)
26        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:871)
27        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:615)
28        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:962)
29        at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1603)
30        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
31        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
32        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
33        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
34        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
35        at java.lang.Thread.run(Thread.java:662)
Hitoshi Ozawa
RE: Why doesn't Knowledgebase portlet deploy??
December 16, 2012 1:26 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Try downloading 6.1.1 version from the Marketplace.

http://www.liferay.com/marketplace/-/mp/application/15197613?_7_WAR_osbportlet_backURL=%2Fmarketplace%3Fp_p_id%3D7_WAR_osbportlet%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_col_id%3Dcolumn-1%26p_p_col_pos%3D1%26p_p_col_count%3D2%26_7_WAR_osbportlet_jspPage%3D%252Fmarketplace%252Fsearch.jsp%26p_r_p_564233524_assetCategoryId%3D0%26p_r_p_564233524_keywords%3Dknowledge
Aaron Paxson
RE: Why doesn't Knowledgebase portlet deploy??
December 16, 2012 4:05 PM
Answer

Aaron Paxson

Rank: Regular Member

Posts: 103

Join Date: July 27, 2010

Recent Posts

Thanks Hitoshi. I actually tried that first, before I went to download it manually.

I seem to have a problem with Marketplace right now. it shows up in my "Purchases", but when I click "Download", it just sits at 'Please Wait". it's only 1.3MB, but after waiting 5 minutes, I refresh the page, and it just goes back to "Download". Weird, huh?
Aaron Paxson
RE: Why doesn't Knowledgebase portlet deploy??
December 16, 2012 4:45 PM
Answer

Aaron Paxson

Rank: Regular Member

Posts: 103

Join Date: July 27, 2010

Recent Posts

Nevermind. I was using Safari, and it wouldn't work. Using Firefox allowed Marketplace to download/install.

Knowledgebase is working fine, now that I installed it from Marketplace.

Thanks Hitoshi