Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
donino pienni
How to install a marketplace plugin on Jboss7?
August 30, 2012 5:26 AM
Answer

donino pienni

Rank: Junior Member

Posts: 82

Join Date: July 2, 2011

Recent Posts

Hi,

I am trying to install the "Private plugin installer" portlet on Liferay 6.1.1.GA2. With tomcat 7 no problem: we can download and then install it, this works like a charm. But with JBoss 7 bundle, when we download it from the marketplace, is is not displaying the "install" option. We can see instead in the browser a ".lpkg" file downloaded, what should we do with it? Is there a way to manually install these .lpkg file in Liferay? Are there specific handlings to install plugins in Jboss 7 Liferay 6.1.1GA2 ?

Thanks
James Falkner
RE: How to install a marketplace plugin on Jboss7?
August 30, 2012 8:42 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

donino donino:
Hi,

I am trying to install the "Private plugin installer" portlet on Liferay 6.1.1.GA2. With tomcat 7 no problem: we can download and then install it, this works like a charm. But with JBoss 7 bundle, when we download it from the marketplace, is is not displaying the "install" option. We can see instead in the browser a ".lpkg" file downloaded, what should we do with it? Is there a way to manually install these .lpkg file in Liferay? Are there specific handlings to install plugins in Jboss 7 Liferay 6.1.1GA2 ?

Thanks


I confirmed this bug - and filed LPS-29570.

To workaround this issue, you can copy the downloaded .lpkg file into your Hot Deploy directory. In my test, I copied it to /tmp/jb/liferay-portal-6.1.1-ce-ga2/deploy and Liferay picked it up and deployed it successfully (but the "Purchased" screen does not reflect this, as I mentioned in the bug report). Thanks for the report!
James Falkner
RE: How to install a marketplace plugin on Jboss7?
August 30, 2012 11:35 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

James Falkner:
donino donino:
Hi,

I am trying to install the "Private plugin installer" portlet on Liferay 6.1.1.GA2. With tomcat 7 no problem: we can download and then install it, this works like a charm. But with JBoss 7 bundle, when we download it from the marketplace, is is not displaying the "install" option. We can see instead in the browser a ".lpkg" file downloaded, what should we do with it? Is there a way to manually install these .lpkg file in Liferay? Are there specific handlings to install plugins in Jboss 7 Liferay 6.1.1GA2 ?

Thanks


I confirmed this bug - and filed LPS-29570.

To workaround this issue, you can copy the downloaded .lpkg file into your Hot Deploy directory. In my test, I copied it to /tmp/jb/liferay-portal-6.1.1-ce-ga2/deploy and Liferay picked it up and deployed it successfully (but the "Purchased" screen does not reflect this, as I mentioned in the bug report). Thanks for the report!


Ok my bug got closed emoticon On further inspection, there is a warning at the top that Marketplace cannot automatically deploy apps you have purchased, and you have to follow the steps I outlined above as the workaround.

I do believe JBoss does, as of 7.x, support hot deploy, it's just that we've not yet written the implementation for this app-specific behavior. I'll file an improvement request.
donino pienni
RE: How to install a marketplace plugin on Jboss7?
August 30, 2012 2:16 PM
Answer

donino pienni

Rank: Junior Member

Posts: 82

Join Date: July 2, 2011

Recent Posts

Thanks a lot James, your workaround worked perfectly!
bla bloup
RE: How to install a marketplace plugin on Jboss7?
September 1, 2012 8:36 AM
Answer

bla bloup

Rank: New Member

Posts: 1

Join Date: August 31, 2012

Recent Posts

you are wonderfull, great help. (was searching for almost a week) Now it works! G
James Falkner
RE: How to install a marketplace plugin on Jboss7?
November 29, 2012 10:59 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

bla bloup:
you are wonderfull, great help. (was searching for almost a week) Now it works! G


BTW, the issue with JBoss 7 and hot deploy has been solved via LPS-29792! This will appear in an upcoming fix for EE, and in 6.2 CE.