Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
lou cat
deploying 2 portlets instead of one?
October 31, 2012 3:32 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Hi! quick and probably newbie question:

I've developed a portlet using eclipse and liferay IDE, but when I deploy it in tomcat, catalina says:
2 portlets for my-portlet was unregistered
2 portlets for my-portlet are available for use


why 2? the portlet is just one!
I'm not seeing any other problem but I'd prefer to fix this and I was wondering if I created the portlet project in the wrong way?
Jitendra Rajput
RE: deploying 2 portlets instead of one?
October 31, 2012 3:55 AM
Answer

Jitendra Rajput

Rank: Liferay Master

Posts: 858

Join Date: January 7, 2011

Recent Posts

Check you portlet.xml , liferay-portlet.xml and lifeay-display.xml it should have 2 portlet entries.
Hitoshi Ozawa
RE: deploying 2 portlets instead of one?
October 31, 2012 6:19 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

There can be several portlets packaged in one war file. Check your portlet.xml file to make sure you only have one portlet for my-portlet defined. Also, check the webapps folder in your liferay installation to make sure there's only one my-portlet deployed.
lou cat
RE: deploying 2 portlets instead of one?
October 31, 2012 8:36 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Thank you guys!

in webapps folder the portlet was only one, but I had two portlet entries in liferay-portlet.xml and portlet.xml, with different portlet names... I guess I messed up something when creating the project and then the class, so eclipse generated two entries emoticon

thanks!!!