Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
S P
Liferay6.1,weblogic10.3.5,primefaces3.2
September 5, 2012 11:14 AM
Answer

S P

Rank: Junior Member

Posts: 65

Join Date: August 6, 2012

Recent Posts

Hi All,
I am able to deploy liferay primefaces3-portlet in tomcat.
as per the sample.
https://github.com/liferay/liferay-faces/tree/master/demos/bridge/primefaces3-portlet
its very nice.Thank you.
but same war file i am trying to deploy in weblogic10.3.5,its not deploying

i am guessing its not able to load this class though class is finding.
web.xml
<servlet-name>Faces Servlet</servlet-name>
<servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
<load-on-startup>1</load-on-startup>
</servlet>

Error : SEVERE: JSF1030: The specified InjectionProvider implementation 'com.bea.faces.WeblogicInjectionProvider' cannot be loaded
Any thoughts or suggestion will be really helpful.

Now i have resolved the above error but now getting class cast error ,i might be doing some wrong ,please guide me.
=============================Portlet.xml========================
<portlet-name>HelloFaces</portlet-name>
<display-name>HelloFaces</display-name>
<portlet-class>org.portletfaces.bridge.GenericFacesPortlet</portlet-class>
<init-param>
<name>javax.portlet.faces.defaultViewId.view</name>
<value>/views/portletViewMode.xhtml</value>
</init-param>


Here is the error message i am getting
ERROR [PortletBagFactory:313] javax.faces.FacesException: javax.faces.FacesException: javax.faces.FacesException: javax.portlet.PortletException: java.lang.ClassCastException: com.liferay.faces.bridge.BridgeImpl
javax.faces.FacesException: javax.faces.FacesException: javax.faces.FacesException: javax.portlet.PortletException: java.lang.ClassCastException: com.liferay.faces.bridge.BridgeImpl
at org.portletfaces.bridge.BridgeFactoryImpl.getBridge(BridgeFactoryImpl.java:77)
at org.portletfaces.bridge.GenericFacesPortlet.getFacesBridge(GenericFacesPortlet.java:291)


I have added in the war file here are the jars: is all the following jars required..i was thinking only this jar should be fine(portletfaces-bridge-2.0.0.jar
) ,i am not sure other jars are required.
bridge-impl-3.1.0-ga1.jar
liferay-faces-bridge-api-3.1.0-ga1
liferay-faces-bridge-impl-3.1.0-ga1


Thanks in Advance.
S P
RE: Liferay6.1,weblogic10.3.5,primefaces3.2
September 6, 2012 2:40 AM
Answer

S P

Rank: Junior Member

Posts: 65

Join Date: August 6, 2012

Recent Posts

I have fixed the issue.
Fernando Nubla Durango
RE: Liferay6.1,weblogic10.3.5,primefaces3.2
September 25, 2012 5:50 AM
Answer

Fernando Nubla Durango

Rank: New Member

Posts: 22

Join Date: September 1, 2009

Recent Posts

S P:
I have fixed the issue.

how you have solved it?
S P
RE: Liferay6.1,weblogic10.3.5,primefaces3.2
September 25, 2012 6:22 AM
Answer

S P

Rank: Junior Member

Posts: 65

Join Date: August 6, 2012

Recent Posts

Hi ,
I have fixed the issue with proper jars,as i was missing the jar version.
I have tried following ways.
Step1>
Portlet jars> in weblogic domain only portal-service.jar and portlet.jar i have placed which came with liferay6.1

Step2> in the custom portlet i have placed Liferay Faces Bridge API-3.1.0-ga1.jar and Liferay Faces Bridge Impl-3.1.0-ga1.jar,primefaces-3.2.jar,jsf-api-2.1.3-b02.jar,jsf-impl-2.1.3-b02.jar.

Also i have followed primefaces-demo,its very good .

Please message if you are getting still problem.