Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Dong Ling
Why can't i see the 'Private Plugin Installer'
September 5, 2012 4:07 AM
Answer

Dong Ling

Rank: New Member

Posts: 2

Join Date: September 3, 2012

Recent Posts

i'm using the liferay-portal-jboss-6.1.1-ce-ga2-20120731***. But when i go to control panel -> Plugin Installation, i can't see the button 'Private Plugin Installer' as mentioned in this linl. http://www.liferay.com/marketplace/-/mp/application/15474932
Do i need to change some setting to see it?
Or this is expected? Really confused why it changes so much than before....

Anyone who knows about this? Thanks in advance for the help~
Attachment

Attachments: Button missing.png (8.5k)
Sampsa Sohlman
RE: Why can't i see the 'Private Plugin Installer'
September 5, 2012 4:41 AM
Answer

Sampsa Sohlman

LIFERAY STAFF

Rank: Regular Member

Posts: 225

Join Date: September 27, 2007

Recent Posts

Hi

You have to choose Store from Control panel and sign in store with your Liferay.com credentials
Attachment

Attachments: marketplace-store.png (31.1k)
James Falkner
RE: Why can't i see the 'Private Plugin Installer'
September 5, 2012 6:12 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Sampsa Sohlman:
Hi

You have to choose Store from Control panel and sign in store with your Liferay.com credentials


And once signed into Marketplace, you have to download and install the "Private Plugins Installer CE" app. Once it's downloaded and installed, you should see the tab for Plugins Installer.
Dong Ling
RE: Why can't i see the 'Private Plugin Installer'
September 5, 2012 11:34 PM
Answer

Dong Ling

Rank: New Member

Posts: 2

Join Date: September 3, 2012

Recent Posts

James Falkner:
Sampsa Sohlman:
Hi

You have to choose Store from Control panel and sign in store with your Liferay.com credentials


And once signed into Marketplace, you have to download and install the "Private Plugins Installer CE" app. Once it's downloaded and installed, you should see the tab for Plugins Installer.



Hi,
Thanks very much for your feedback. I just installed the App. But still cannot see the button. Do i need to restart my Jboss?
marlon lopez
RE: Why can't i see the 'Private Plugin Installer'
September 13, 2012 11:15 PM
Answer

marlon lopez

Rank: New Member

Posts: 1

Join Date: September 13, 2012

Recent Posts

hi,

i've downloaded liferay latest version, used my credential for marketplace requests and bah!
i tried to deploy a custom portlet, but i dont see the button :S

whats wrong??
James Falkner
RE: Why can't i see the 'Private Plugin Installer'
September 14, 2012 5:58 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

marlon lopez:
hi,

i've downloaded liferay latest version, used my credential for marketplace requests and bah!
i tried to deploy a custom portlet, but i dont see the button :S

whats wrong??



Since JBoss does not support hot deploy (from the perspective of Liferay), you have to manually deploy the .lpkg file that you download from Marketplace. You should have seen the helpful (but easy to miss) note at the top of the Control Panel -> Marketplace -> Purchased screen (see attachment). So, when you click "Download" in Control Panel -> Marketplace ->Store, it will download a .lpkg file to your local system, and then you must manually copy this file into the Liferay "Hot Deploy" directory. In my case, I had to execute this command using my terminal (JBoss was installed into /tmp/jb):

1cp ~/Downloads/15474932_15997511_15998278.lpkg /tmp/jb/liferay-portal-6.1.1-ce-ga2/deploy
Attachment

Attachments: no-hot-deploy-jboss.png (44.3k)
Changhai Wang
RE: Why can't i see the 'Private Plugin Installer'
September 29, 2012 2:33 AM
Answer

Changhai Wang

Rank: New Member

Posts: 1

Join Date: September 28, 2012

Recent Posts

I Seems like i can find the 'Private Plugin Installer' after copy the file to ~/deploy/ , thanks a lot
mrz khd
RE: Why can't i see the 'Private Plugin Installer'
January 26, 2014 10:04 PM
Answer

mrz khd

Rank: New Member

Posts: 1

Join Date: January 25, 2014

Recent Posts

hi guys,
i've downloaded plugin and successfully install it, but it doesn't appear in control panel,
I'm on "Liferay Portal Community Edition 6.2.0 CE GA1 (Newton / Build 6200 / November 1, 2013)" with tomcat.

and when i try via :control panel->App Manager->install->upload war" and upload file, it show green message that installed successfully but my portlet not show neither in Plugins Configuration or when i want add portlet in Edit Page mode.

may you help me emoticon
James Falkner
RE: Why can't i see the 'Private Plugin Installer'
January 27, 2014 10:05 PM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

mrz khd:
hi guys,
i've downloaded plugin and successfully install it, but it doesn't appear in control panel,
I'm on "Liferay Portal Community Edition 6.2.0 CE GA1 (Newton / Build 6200 / November 1, 2013)" with tomcat.

and when i try via :control panel->App Manager->install->upload war" and upload file, it show green message that installed successfully but my portlet not show neither in Plugins Configuration or when i want add portlet in Edit Page mode.

may you help me emoticon


Hey mrz, which portlet did you attempt to install? The green message indicates that the file was uploaded successfully but the actual deployment may have failed - check your log file (if using Tomcat, it will be in tomcat-xx.xx.xx/logs/catalina.out) and see if there are errors during deployment.