Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
Chris van Knippenberg
Oracle Idm in combination with document library
August 14, 2012 6:53 AM

Chris van Knippenberg

Rank: New Member

Posts: 3

Join Date: August 14, 2012

Recent Posts

We’re using liferay 6.0.5 CE. Via url’s we’ve made several documents available on our site. These are stored in document library. This worked fine. Since we introduced SSO via Oracle Identity Management, everytime we try to open a document and we’re not logged in, liferay wants us to log in.

When I log in first, I'm able to click on a link and the document opens without problems. But as long as you’re not logged in, performing the same action isn't possible anymore.

After reading documentation and forum posts I thought that when you're nog logged in, you should have the permissions of the guest role and those should be ok to view documents.

The urls which used to work look like this: http://www.environment.domain/c/document_library/get_file?uuid=7f0cd742-59fa-4232-9984-e0d99760f89d&groupId=10803

When we replace this urls by hand with something like this, it all works fine again: http://www.environment.domain/documents/10803/59201/Tentamenprocedures+2010-11.pdf

Since this is not a very error-free workaround we’re trying to find a way to solve this. Until now I’ve tried the following. I’ve changed the rights of the guest role. In the control panel I added view rights to the guest role on documentlibrary. No effect.

According to a post I found online, I had to check the view checkbox. Save it, logout, login again with my administrator account, uncheck the view checkbox, logout, login again and check it again. Otherwise the change wouldn’t be saved. However, still no effect.

Does somebody know if this could is a bug in 6.0.5 or if there's something we can do to make it work again ?

Thanks in advance.

Participate in the State of Liferay Community 2017. Help the community and even win some prizes!