Combination View Flat View Tree View
Threads [ Previous | Next ]
Thomas Berg
LocaleException during startup
August 5, 2012 2:33 AM

Thomas Berg

Rank: Regular Member

Posts: 134

Join Date: September 7, 2009

Recent Posts


Using Liferay 6.1.1 CE GA2. I get this exception during startup. Haven't noticed any problems related to this but would of course like to know why this happens:

 111:23:09,895 INFO  [pool-2-thread-1][AutoDeployDir:106] Auto deploy scanner started for /opt/portal/liferay/servers/liferay-portal-6.1.1-ce-ga2/deploy
 211:23:12,629 ERROR [pool-2-thread-1][PortalInstances:468] com.liferay.portal.LocaleException com.liferay.portal.LocaleException
 4        at
 5        at
 6        at
 7        at
 8        at
 9        at com.liferay.portal.util.PortalInstances._initCompany(
10        at com.liferay.portal.util.PortalInstances.initCompany(
11        at com.liferay.portal.servlet.MainServlet.initCompanies(
12        at com.liferay.portal.servlet.MainServlet.init(
13        at javax.servlet.GenericServlet.init(

Hitoshi Ozawa
RE: LocaleException during startup
August 5, 2012 4:16 AM

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

I was also getting some errors when I first startup liferay. I was wondering if you're getting the error during when you first started up liferay or if you've added something in the document and media library.
Soeren Unruh
RE: LocaleException during startup
August 8, 2012 3:10 AM

Soeren Unruh

Rank: New Member

Posts: 1

Join Date: April 16, 2010

Recent Posts


I found the reason for this exception. It is coming from DDMStructureLocalServiceImpl.validateLanguages().

This method checks whether the default locale specified in the document library structure (com/liferay/portal/events/dependencies/document-library-structures.xml) is contained in the available locales of the company.

These (default) document library structures are created in each company if they do not exist.

I suppose, you removed all or one of them and also removed the en_US locale from one or all of your companies.

You could try to override in your, removing as a workaround.


Michele Giacobazzi
RE: LocaleException during startup
August 22, 2012 8:01 AM

Michele Giacobazzi

Rank: Junior Member

Posts: 40

Join Date: September 9, 2011

Recent Posts

I solved this problem deleting a space:


1locales=it_IT, en_US

gives the error


does not!