Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
EFFA ZARINA EZN
mail problems
July 23, 2012 9:12 PM
Answer

EFFA ZARINA EZN

Rank: New Member

Posts: 7

Join Date: July 18, 2012

Recent Posts

hye all, i just want to ask something,

why my portal did not sent the email notification to user for the password if the user already sign in,
if the user forgot the password, then enter the email and verification, it should send the new password to user email..
only the message "your request processed successfully " is display, but no email is sent.

i am using liferay 6.0.6 bundled with tomcat 6.0.29 running on windows XP.

i am only modifying the portal-ext.properties like this>>




and this is how i manage server administration (mail) in control panel for the portal.



thank you.. emoticon
Jignesh Vachhani
RE: mail problems
July 23, 2012 9:48 PM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 794

Join Date: March 10, 2008

Recent Posts

First you check in gmail account whether pop3 or imap (whatever you used) is enabled or not .
If its enable then please use below settings for pop3 or imap

For pop3 or imap (Incoming):

Host name : pop.gmail.com
Port for pop3 : 995 (As per screenshot ,you mentioned wrong port 110 i think)


For SMTP (Sending a mail or Outgoing) :
Host name: smtp.gmail.com
port : 465
And use secure connection option from control panel or set mail.session.mail.smtp.auth=true for sending a mail.
EFFA ZARINA EZN
RE: mail problems
July 23, 2012 10:55 PM
Answer

EFFA ZARINA EZN

Rank: New Member

Posts: 7

Join Date: July 18, 2012

Recent Posts

Jignesh Vachhani:
First you check in gmail account whether pop3 or imap (whatever you used) is enabled or not .
If its enable then please use below settings for pop3 or imap

For pop3 or imap (Incoming):

Host name : pop.gmail.com
Port for pop3 : 995 (As per screenshot ,you mentioned wrong port 110 i think)


For SMTP (Sending a mail or Outgoing) :
Host name: smtp.gmail.com
port : 465
And use secure connection option from control panel or set mail.session.mail.smtp.auth=true for sending a mail.



Jignesh, i have re update all like you suggest but, it still does not work emoticon
Jignesh Vachhani
RE: mail problems
July 23, 2012 11:21 PM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 794

Join Date: March 10, 2008

Recent Posts

Are you able to see any error in server console ?
I would suggest to use setting either it from property file or from control panel.
And once run clear database cache from control panel >> server setting
Jignesh Vachhani
RE: mail problems
July 24, 2012 12:24 AM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 794

Join Date: March 10, 2008

Recent Posts

Please see screenshot here: Its working for me.

So try above solution which i have given.
Attachment

Attachments: mail.jpg (70.6k)
Tejas Kanani
RE: mail problems
July 24, 2012 12:32 AM
Answer

Tejas Kanani

Rank: Liferay Master

Posts: 655

Join Date: January 6, 2009

Recent Posts

Check if POP is enabled from Gmail.
Refer this for more details.
Enabling POP
EFFA ZARINA EZN
RE: mail problems
July 24, 2012 1:15 AM
Answer

EFFA ZARINA EZN

Rank: New Member

Posts: 7

Join Date: July 18, 2012

Recent Posts

Jignesh, i already have configure the mail server setting just same like you did but still not working.

Tejas, the pop in gmail is already enable..

is there anything that i missed out??
anyway, thanks for suggestion.. emoticon
Jignesh Vachhani
RE: mail problems
July 24, 2012 1:18 AM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 794

Join Date: March 10, 2008

Recent Posts

AS I suggest ,

Either apply this setting from portal-ext.properties or from Control panel.
Try to remove DB once if there is no any data populated.
And configure it using Control panel.