Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Anita Katakkar
Issues with Liferay 6.1 and IE7 Classic Theme Child Menu Items
July 20, 2012 9:07 AM
Answer

Anita Katakkar

Rank: New Member

Posts: 3

Join Date: July 20, 2012

Recent Posts

Description of problem:

I am using Liferay 6.1.10 and we need to support IE7. It seems that there is some odd behaviour when child menu items are clicked. In Figure 1 (Chrome + classic theme), a menu item is clicked and normal behaviour occurs. In Figure 2 (IE7 + classic theme), when a child menu item is clicked it seems that the “Home” menu opens automatically. The "Home" menu automatically opens when clicking on any child menu item that does not have "Home" as a parent.

Please note: no customizations have been added to the classic theme.

If anyone knows of a fix for this issue, please let me know. Thank you.

Figure 1: Chrome + classic theme


Figure 2: IE7 + classic theme (as viewed in Microsoft expression)
Hitoshi Ozawa
RE: Issues with Liferay 6.1 and IE7 Classic Theme Child Menu Items
July 20, 2012 8:51 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Sorry but I haven't this error before. Did you modify anything or is this the downloaded liferay without changing anything (ie. no change in theme nor any other settings)?
Anita Katakkar
RE: Issues with Liferay 6.1 and IE7 Classic Theme Child Menu Items
July 23, 2012 6:04 AM
Answer

Anita Katakkar

Rank: New Member

Posts: 3

Join Date: July 20, 2012

Recent Posts

Hi Hitoshi,

Thank you for your response.

Yes - this is on an unmodified downloaded version of Liferay 6.1 viewed with IE7. To confirm this, I've just performed the following steps:

1) Re-install Liferay 6.1 (i.e. liferay-portal-tomcat-6.1.0-ce-ga1-20120106155615760)
2) Build the menu structure within the Control Panel

i.e. Control Panel -> Site Pages -> Public Pages:
Welcome
-> welcome1 (child page)
-> welcome2 (child page)
Menu2
Menu3
Menu4
Menu5
-> Menu51 (child page)
-> Menu52 (child page)
-> Menu53 (child page)

3) Go Back to Liferay (Public Pages)
4) Click on Menu53 with the following results (as viewed in IE7 using Microsoft expression OR IE8 using a virtual server):


*** New discovery ***:
When viewing the above menu as an unauthenticated user, the same results did not occur (see image below). Is there another theme used for unauthenticated users?

I did find however that in IE7 the menu structure did slip behind the welcome portal (a defect that I've read about for IE7). In IE8 this works fine.

Please let me know if you can shed any light on this situation. Thank you,

Anita
Anita Katakkar
RE: Issues with Liferay 6.1 and IE7 Classic Theme Child Menu Items
July 24, 2012 7:20 AM
Answer

Anita Katakkar

Rank: New Member

Posts: 3

Join Date: July 20, 2012

Recent Posts

Another discovery. This behaviour only occurs when you are logged in with admin privileges.
David Kubitza
RE: Issues with Liferay 6.1 and IE7 Classic Theme Child Menu Items
February 7, 2013 11:19 PM
Answer

David Kubitza

Rank: New Member

Posts: 10

Join Date: May 13, 2012

Recent Posts

Did you solve this problem?

I have the same issue and it's not related to the admin role but to UPDATE permissions on the current page. These permissions show up some new script that manipulates the menu.

If you change this line it will work fine again: https://github.com/liferay/liferay-portal/blob/master/portal-web/docroot/html/common/themes/bottom_js.jspf#L160

Btw.: You don't need a sub menu for "Home" the issue will stay the same even without, it will just not be so clearly visible what is happening.