Forums

Home » Liferay IDE » English

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Michael Kroll
Eclipse juno + liferay ide
July 4, 2012 10:43 PM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

Hello,

I try to use eclipse juno with the liferay ide plugin, but I can find the plugin in eclipse.
There is no entry under 'File > New... > ' or anywhere else.
I have used this one 'http://releases.liferay.com/tools/ide/eclipse/juno/nightly/' to install it directly in eclipse, works fine without any errors.
When I look unter 'Help > About Eclipse' there is a Liferay icon, with the version infomation (1.6.0.v201207040948).
Anything looks good but I can find the Liferay plugin in Eclipse, someone has an idea on this ?!

Regards
Michael
Gregory Amerson
RE: Eclipse juno + liferay ide
July 4, 2012 11:05 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

What version of Eclipse Juno do you have? Can you tell me what the contents of the Help > About screen text is?
Gregory Amerson
RE: Eclipse juno + liferay ide
July 4, 2012 11:50 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

What likely has happened is that you have the Eclipse Java or Eclipse SDK package/distribution. So that means it does not have all the dependencies for Liferay IDE, namely the WebTools features. If that is the case you can install them from the Juno repository.

I am going to try update the Liferay IDE feature to include the properly enumerated list of features that would allow a user to install Liferay IDE feature into an Eclipse install and it automatically pull in features from Juno repository.
Michael Kroll
RE: Eclipse juno + liferay ide
July 5, 2012 1:41 AM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

Hi,

thanks for your fast answer..
I have added a picture from the Eclipse about screen, so you can see which version I use and which plugins are installed.

Regards
Michael
Attachment

Attachments: EclipseVersion.png (59.9k)
Gregory Amerson
RE: Eclipse juno + liferay ide
July 5, 2012 2:08 AM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Can you try the following to see what it says?
  1. Open Console View
  2. In view menu click on "Host OSGi Console"
  3. at the prompt type "start com.liferay.ide.eclipse.project.ui"
  4. post here any error messages you see
Michael Kroll
RE: Eclipse juno + liferay ide
July 5, 2012 4:28 AM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

This is my error message:

WARNING: This console is connected to the current running instance of Eclipse!osgi> start com.liferay.ide.eclipse.project.ui
gogo: BundleException: The bundle "com.liferay.ide.eclipse.project.ui_1.6.0.v201207040948 [846]" could not be resolved. Reason: Missing Constraint: Require-Bundle: com.liferay.ide.eclipse.project.core; bundle-version="0.0.0"
osgi>


Then I tried to install the OSGI bundle from WebTools and get this error message here:

An error occurred while collecting items to be installed
session context wasemoticonprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Multiple problems occurred while downloading.
Unable to read repository at http://download.eclipse.org/libra/milestones/S-0.2.0M1-201108160923/plugins/org.eclipse.libra.facet_0.1.1.201108160923.jar.
Server returned HTTP response code: 403 for URL: http://download.eclipse.org/libra/milestones/S-0.2.0M1-201108160923/plugins/org.eclipse.libra.facet_0.1.1.201108160923.jar

I think that the osgi bundle is my problem......

Regards
Michael
Gregory Amerson
RE: Eclipse juno + liferay ide
July 5, 2012 6:36 AM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Can you try this command from osgi console?

start com.liferay.ide.eclipse.project.core

If that fails because it can't find another bundle, can you just keep typing in the missing bundles until we find the one that it is actually missing?
Gregory Amerson
RE: Eclipse juno + liferay ide
July 5, 2012 7:18 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

In the future, hopefully this will not be problem if there are missing dependencies:

http://issues.liferay.com/browse/IDE-642
Michael Kroll
RE: Eclipse juno + liferay ide
July 5, 2012 9:22 PM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

Gregory Amerson:
Can you try this command from osgi console?

start com.liferay.ide.eclipse.project.core

If that fails because it can't find another bundle, can you just keep typing in the missing bundles until we find the one that it is actually missing?



WARNING: This console is connected to the current running instance of Eclipse!osgi> start com.liferay.ide.eclipse.project.core
gogo: BundleException: The bundle "com.liferay.ide.eclipse.project.core_1.6.0.v201207040948 [805]" could not be resolved. Reason: Missing Constraint: Require-Bundle: com.liferay.ide.eclipse.core; bundle-version="0.0.0"
osgi>
Gregory Amerson
RE: Eclipse juno + liferay ide
July 5, 2012 11:03 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Can you try:

start com.liferay.ide.eclipse.core
Michael Kroll
RE: Eclipse juno + liferay ide
July 6, 2012 12:32 AM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

Gregory Amerson:
Can you try:

start com.liferay.ide.eclipse.core


WARNING: This console is connected to the current running instance of Eclipse!osgi> start com.liferay.ide.eclipse.core
gogo: IllegalArgumentException: Cannot coerce start(String) to any of [(Bundle[])]
osgi>
Gregory Amerson
RE: Eclipse juno + liferay ide
July 6, 2012 12:39 AM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Looks like a bad install/copy of the com.liferay.ide.eclipse.core plugin.

Try uninstalling the Liferay IDE feature and then re-installing. (You can uninstall from the Help > About > Configuration > Installed Feature > Liferay IDE, then click "Uninstall"). Then try reinstalling it again.
Michael Kroll
RE: Eclipse juno + liferay ide
July 6, 2012 12:58 AM
Answer

Michael Kroll

Rank: New Member

Posts: 17

Join Date: March 1, 2010

Recent Posts

Gregory Amerson:
Looks like a bad install/copy of the com.liferay.ide.eclipse.core plugin.

Try uninstalling the Liferay IDE feature and then re-installing. (You can uninstall from the Help > About > Configuration > Installed Feature > Liferay IDE, then click "Uninstall"). Then try reinstalling it again.


I don't now why, but after uninstall and install the Liferay IDE all works fine.
Yesterday morning I try it with a fresh installed Eclipse and it don't work.

Many thanks.

Regards
Michael
Gregory Amerson
RE: Eclipse juno + liferay ide
July 6, 2012 1:11 AM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Glad you are up and running!
Racel Placek
RE: Eclipse juno + liferay ide
July 8, 2012 4:49 AM
Answer

Racel Placek

Rank: New Member

Posts: 1

Join Date: July 8, 2012

Recent Posts

Michael Kroll:
Gregory Amerson:
Looks like a bad install/copy of the com.liferay.ide.eclipse.core plugin.

Try uninstalling the Liferay IDE feature and then re-installing. (You can uninstall from the Help > About > Configuration > Installed Feature > Liferay IDE, then click "Uninstall"). Then try reinstalling it again.


I don't now why, but after uninstall and install the Liferay IDE all works fine.
Yesterday morning I try it with a fresh installed Eclipse and it don't work.

Many thanks.

Regards
Michael


I had the same problem with Liferay IDE plugin in my Eclipse Juno on Windows 7. The plugin was visible in Eclipse About dialog but you cannot use it from menu. Problem was with missing admin privilages for eclipse. Solution is run eclipse as an administrator. For some reason eclipse didn't see some packages. After run eclipse as an admin then install the plugin and problem is gone.
Gregory Amerson
RE: Eclipse juno + liferay ide
July 8, 2012 6:10 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1028

Join Date: February 16, 2010

Recent Posts

Racel Placek:
Michael Kroll:
Gregory Amerson:
Looks like a bad install/copy of the com.liferay.ide.eclipse.core plugin.

Try uninstalling the Liferay IDE feature and then re-installing. (You can uninstall from the Help > About > Configuration > Installed Feature > Liferay IDE, then click "Uninstall"). Then try reinstalling it again.


I don't now why, but after uninstall and install the Liferay IDE all works fine.
Yesterday morning I try it with a fresh installed Eclipse and it don't work.

Many thanks.

Regards
Michael


I had the same problem with Liferay IDE plugin in my Eclipse Juno on Windows 7. The plugin was visible in Eclipse About dialog but you cannot use it from menu. Problem was with missing admin privilages for eclipse. Solution is run eclipse as an administrator. For some reason eclipse didn't see some packages. After run eclipse as an admin then install the plugin and problem is gone.


Thanks for that info about running it as administrator. Eclipse needs to install new files and modify existing ones in its installation folder during an update. So if you have installed Eclipse under a protected directory (Program Files) it will have this issue. Personally I always put Eclipse in a custom top-level directory, "D:/eclipse-juno", or similar to avoid such OS interference.
Sanjay Joy
RE: Eclipse juno + liferay ide
November 7, 2012 11:11 PM
Answer

Sanjay Joy

Rank: New Member

Posts: 6

Join Date: March 6, 2011

Recent Posts

Hi,
I am also facing the same problem. Even I started Eclipse Juno with Admin but same exception is throwing

Unable to read repository at file:/D:/Practice/Portal/eclipse/p2/org.eclipse.equinox.p2.repository/cache/content-1639072965.xml.
The markup in the document preceding the root element must be well-formed.

--
Thanks
Anand Shankar