Forums

Home » Liferay Portal » Español » 3. Desarrollo

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Verónica Sevillano
Primer acceso en español
October 17, 2008 3:52 AM
Answer

Verónica Sevillano

Rank: New Member

Posts: 14

Join Date: October 1, 2008

Recent Posts

Hola a todos, a ver si pueden ayudarme con el siguiente problema.

Tengo un portal montado en la comunidad guest pues será visible para todos. El problema está en que al acceder la primera vez sale en inglés y no me muestra el contenido de los artículos, supongo que porque estarán escritos en español. Si cambio el idioma a español, me aparece todo bien, pero al borrar el historial de exploración al completo y volver a acceder a /web/guest/home vuelve a aperecer en inglés.
¿Alguien sabe cómo hacer para que cualquier usuario la primera vez que acceda ya tenga el idioma español? Sería de gran ayuda que alguien contestara porque me urge solucionar este problema

Un saludo
Julio Camarero
RE: Primer acceso en español
October 21, 2008 5:22 AM
Answer

Julio Camarero

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1662

Join Date: July 15, 2008

Recent Posts

Hola Verónica,

puedes probar a hacer con Enterprise Admin, en portal --> Settings
y alli cambiar el Language Display.

Un saludo!

Julio Camarero
Liferay España
Verónica Sevillano
RE: Primer acceso en español
October 23, 2008 1:59 AM
Answer

Verónica Sevillano

Rank: New Member

Posts: 14

Join Date: October 1, 2008

Recent Posts

Hola Julio, he probado a hacer lo que me dijiste, pero funciona mientras no borre la caché del navegador o la carpeta work del tomcat. Porque después de eso, me vuelve a poner el lenguaje en inglés.

Creía que había solucionado el problema añadiendo las siguientes líneas al archivo system-ext.properties, pero no es así. Con esto consigo que se me vean los artículos pero si le doy a leer más de una noticia, me muestra el título pero no el contenido, Y tampoco me aparece el contenido en el resto de páginas.
Si alguien sabe como poner solución a ésto lo agradecería porque me estoy quedando sin ideas.

Gracias, un saludo
Verónica Sevillano
RE: Primer acceso en español
October 23, 2008 5:04 AM
Answer

Verónica Sevillano

Rank: New Member

Posts: 14

Join Date: October 1, 2008

Recent Posts

Bueno, pues después de seguir probando, ahora para que me aparezcan los contenidos tengo que hacerlo de la siguiente manera.
Si creo un artículo y lo publico lo veo yo pero todo aquel que acceda a mi máquina no. Ahora bien, si creo un artículo y luego lo edito y lo vuelvo a guardar, ya no hay problema.

¿Alguien sabe a qué se debe este comportamiento tan extraño?

Un saludo
Cesar Ingaruca
RE: Primer acceso en español
October 29, 2008 7:31 AM
Answer

Cesar Ingaruca

Rank: Regular Member

Posts: 143

Join Date: August 12, 2008

Recent Posts

Hola Julio, tengo el mismo problema que verónica. Eh intentado lo que me dices pero el lenguage no se guarda si borro las cockies esto es asi? porque cuando alguien desde otro lugar ingresa por primera vez al portal los titulos de los portlets aparecen en ingles.

Y no se muestran mis portlets de contenido. Necesito saber como solucionarlo porfavor.

Espero tu ayuda.

Salu2.
Cesar Ingaruca
RE: Primer acceso en español
October 29, 2008 8:04 AM
Answer

Cesar Ingaruca

Rank: Regular Member

Posts: 143

Join Date: August 12, 2008

Recent Posts

Hola denuevo,
Ahora que e estado viendo al cambiar el idioma de mi articulo a INGLES recien me los muestra pero mi idioma por defecto es español. Pero cuando alguien se conecta al portal aparece en INGLES la primera vez.

Quizá exista otra forma de cambiar el idioma default del Liferay .

Alguna otra sugerencia?.
Julio Camarero
RE: Primer acceso en español
November 10, 2008 3:48 AM
Answer

Julio Camarero

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1662

Join Date: July 15, 2008

Recent Posts

Hola,

he intentado reproducir el problema, pero a mi sí que me funciona bien.

Cambio el lenguaje y luego entrando desde otras máquinas se mantiene el idioma. (César, esto no se guarda en las cookies sino en la base de datos).

Puedes intentar depurar qué pasa cuando entras al portal en LoginPreAction.java para ver qué error da mientras carga los locales.

Un saludo.

Julio Camarero
Liferay España
Cesar Ingaruca
RE: Primer acceso en español
November 10, 2008 8:46 AM
Answer

Cesar Ingaruca

Rank: Regular Member

Posts: 143

Join Date: August 12, 2008

Recent Posts

Hola, como hago la depuración?. Y en que parte de la base de datos se guarda? para poder verificar si lo hace porque cuando bajo el servicio del tomcat e ingreso a settings.. me vuelve a aparecer el lenguage English como defecto y a pesar de que lo cambie por español yo abro el portal desde mi firefox y aparece en ingles.

Y ahora que e estado viendo en system.properties hay
user.country=US
user.language=en
eso influye en algo?, espero tus respuestas.

Saludos.
Julio Camarero
RE: Primer acceso en español
November 11, 2008 2:00 AM
Answer

Julio Camarero

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1662

Join Date: July 15, 2008

Recent Posts

Hola César,

para depurar lo mejor es que uses un entorno de desarrollo porque te permite poner puntos de parada en distintas partes del código e ir ejecutando instrucción por instrucción.

Prueba a poner en el portal-ext.properties

user.country=ES
user.language=es

Un saludo

Julio Camarero
Liferay España
Cesar Ingaruca
RE: Primer acceso en español
November 11, 2008 8:47 AM
Answer

Cesar Ingaruca

Rank: Regular Member

Posts: 143

Join Date: August 12, 2008

Recent Posts

Hola Julio,
probe seteando en los properties(system-ext y portal-ext) pero sin efecto, me sigue cargando por defecto el idioma ingles, en la clase que me escribiste en el anterior Post LoginPreAction.java solo hay esto :

1    public void run(HttpServletRequest request, HttpServletResponse response) {
2        if (_log.isDebugEnabled()) {
3            _log.debug("Running " + request.getRemoteUser());
4        }
5    }
6
7    private static Log _log = LogFactory.getLog(LoginPreAction.class);


¿Es esta la clase en la que tengo que depurar? que es lo que tengo que obtener? .
No se que puede estar pasando me es necesario que este en español , por cierto ¿En que tabla se graba el idioma?.


y ahora que acabo de ver en propiedades del sistema en el portlet de Admin me aparece esto

user.country ES
user.language es
es decir si lo coge del system-ext-properties pero al abrir el portal por primera vez sigue apareciendo en ingles

que clase es la que al acceder se carga el lenguage? derrepente por ahi podria estar el problema
o no se que podría estar pasando?

Saludos.
Federico Suarez
RE: Primer acceso en español
November 12, 2008 4:58 AM
Answer

Federico Suarez

Rank: New Member

Posts: 1

Join Date: November 6, 2008

Recent Posts

Hola cesar, lo que dice julio funciona. Lo unico que puede ser es que se esten equivocando de pagina que contiene el portlet "enterprise admin" o si estas en español "administracion de la empresa" asegurate de elegir en el menu pop up en "mis espacios web" en "guest" tu pagina de administracion... la que vas a usar para administrar. ahi si no esta ese portlet de administracion de la empresa agregalo. esta clasificado en "administracion" al añadir portlet. una vez que tengas el portlet de "administracion de la empresa", ahi si en "settings" o "configuracion" elegis el language o idioma por defecto despues lo guardas, y con eso queda funcionando desde otras maquinas. Espero haber ayudado saludos!
Solo Imr
RE: Primer acceso en español
November 12, 2008 10:47 PM
Answer

Solo Imr

Rank: Junior Member

Posts: 38

Join Date: October 9, 2008

Recent Posts

Hola!
Aparte de tener configurado portal-ext.properties y system-ext.properties para español como se menciona, verifica que los usuarios en la base también tengan el lenguaje en español . Esto es en la tabla USER_ , el campo "LANGUAGEID" .

suerte!
Cesar Ingaruca
RE: Primer acceso en español
November 13, 2008 7:29 AM
Answer

Cesar Ingaruca

Rank: Regular Member

Posts: 143

Join Date: August 12, 2008

Recent Posts

Despúes de varios intentos ya logré hacerlo, al parecer como las otras maquinas abrieron el portal cuando estaba en ingles esto se quedo grabado en las cookies(creo) y aunque yo cambiaba en el portal seguia viendose en ingles. Y bueno al borrar las cookies ya se pudo ver según el lenguage español gracias por todo Saludos.
Paco Melia C.
RE: Primer acceso en españo
November 14, 2008 12:28 PM
Answer

Paco Melia C.

Rank: Junior Member

Posts: 28

Join Date: April 16, 2008

Recent Posts

Hola a todos,

a mi me pasa más o menos lo mismo, pero no consigo solucionarlo. A ver si podéis echarme una mano.

Si utilizo 'Enterprise Admin, en portal --> Settings' y cambio el idioma y la zona horaria, todo funciona correctamente, entro desde cualquier sitio y aparece todo en Español. (al menos las páginas públicas de Guest, que es lo que más me preocupa).

Las pruebas las hago siempre borrando cookies, temporales, ... antes de entrar en la página.

El problema es que si se reinicia tomcat, estos cambios no se mantienen, vuelve a aparecer inglés y Zona horaria de Samoa (esto parece ser que es un bug, y ya está reportado). A parir de entonces (si no se vuelve a configurar de nuevo), las páginas aparecen en inglés.

Para evitar este problema, configuro los system-ext y portal-ext. Con el portal-ext no tengo problema, en los desplegables para elegir idioma aparecen los que yo le indico (español e inglés). Pero con el system-ext, donde he puesto user.country=ES y user.language=es no tengo suerte, y es que entro de nuevo, después de reiniciar, en 'Enterprise Admin, en portal --> Settings' y el idioma está en inglés (y las páginas también). Pero sí que tiene algún efecto, ya que al redactar un nuevo artículo aparece el idioma por defecto Español, dónde antes aparecía inglés, y lo mismo pasa al crear una página.

Mi pregunta es si alguien ha conseguido configurar las preferencias de idioma cuando se reinicia el servidor, para que se quede en otro idioma que no sea Inglés.

Muchas gracias

Paco
Solo Imr
RE: Primer acceso en españo
November 15, 2008 7:49 AM
Answer

Solo Imr

Rank: Junior Member

Posts: 38

Join Date: October 9, 2008

Recent Posts

Hola Paco;
Lo que nosotros hicimos fueron los pasos que se han indicado en este hilo ( en liferay 5.1.1 )

1) En system-ext.properties , agregar/modificar los parámetros: user.country , user.language y user.timezone
2) En portal-ext.properties , agregar/modificar el parámetro: locales
3) En la tabla USER_ , modificar los campos LANGUAGEID y TIMEZONEID (para todos los usuarios )

En ningún momento hacemos algún cambio de idioma / timezone desde "Enterprise Admin --> Settings" (por el bug que tu indicas ).

Luego de estos cambios, todos los portlets se ven en español, y en 'Enterprise Admin --> Settings' ( que creo pasa a llamarse Configuración o algo por el estilo), los parámetros de idioma son los que configuramos en los archivos .properties.

Luego de reiniciar los servidores, los parámetros se han mantenido correctamente.
Paco Melia C.
RE: Primer acceso en español
November 15, 2008 11:07 AM
Answer

Paco Melia C.

Rank: Junior Member

Posts: 28

Join Date: April 16, 2008

Recent Posts

Muchas gracias, me faltaba lo de la tabla User_

He entrado en dicha tabla y aparecía un registro de un usuario "default@liferay.com" que no sabía que existía. El languageId estaba en en_US y el timeZoneId era GMT. Ha sido cambiar estos valores a es_ES y a Europe/Paris (solo para este usuario), y ya funciona.

Bueno, esperemos que la próxima versión ya tenga el fallo corregido, pero hasta entonces solucionado el problema.

Gracias.

Paco
Solo Imr
RE: Primer acceso en español
November 15, 2008 1:31 PM
Answer

Solo Imr

Rank: Junior Member

Posts: 38

Join Date: October 9, 2008

Recent Posts

Creo que "default@liferay.com" sería el usuario "guest".
Bueno, resuelto el problema ;-)
salu2