Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Pranay R Patadiya
Error in Adding CMIS Alf Repository
June 5, 2012 5:08 AM
Answer

Pranay R Patadiya

Rank: Regular Member

Posts: 181

Join Date: February 22, 2010

Recent Posts

Hi Friends,

I am trying to add Alfresco Repository through CMIS as shown.
I am following:
1) Add Repository
2) Add Name of Repo
3) Add Desc
4)Select CMIS Repositroy(Atompub) from Repository type
5) Atompub URL (localhost:800/alfresco/service/cmis)

Once I click on "Save" it will give me error like: "Please verify your repository configuration parameters. "

Any Help ??
James Falkner
RE: Error in Adding CMIS Alf Repository
June 5, 2012 8:50 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Pranay R Patadiya:
Hi Friends,

I am trying to add Alfresco Repository through CMIS as shown.
I am following:
1) Add Repository
2) Add Name of Repo
3) Add Desc
4)Select CMIS Repositroy(Atompub) from Repository type
5) Atompub URL (localhost:800/alfresco/service/cmis)

Once I click on "Save" it will give me error like: "Please verify your repository configuration parameters. "

Any Help ??


You must also configure some other things, as outlined in Alex's Blog post and in the official docs.

In particular, you have to set session.store.password=true, and company.security.auth.type=screenName, and then ensure that your username/password on Liferay is the same as is used on Alfresco (this is normally ensured through LDAP-backed SSO solutions).
Pranay R Patadiya
RE: Error in Adding CMIS Alf Repository
June 6, 2012 4:00 AM
Answer

Pranay R Patadiya

Rank: Regular Member

Posts: 181

Join Date: February 22, 2010

Recent Posts

Hi James,

Thanks for you response, I will try the solution and will update.

Thanks,
Pranay
Pranay R Patadiya
RE: Error in Adding CMIS Alf Repository
June 6, 2012 4:11 AM
Answer

Pranay R Patadiya

Rank: Regular Member

Posts: 181

Join Date: February 22, 2010

Recent Posts

Hi James,

I have tried with by addid the properties you told but getting the same again.

Let me attache the screen shot of error so you have better idea for that.

Regards,
Pranay
Attachment

Attachments: error.PNG (26.5k)
James Falkner
RE: Error in Adding CMIS Alf Repository
June 6, 2012 8:39 AM
Answer

James Falkner

Community Moderator

Rank: Liferay Legend

Posts: 1406

Join Date: September 17, 2010

Recent Posts

Hmm.. can you login to alfresco itself using the same username/password as Liferay?
Abhay Chaware
RE: Error in Adding CMIS Alf Repository
September 18, 2013 10:05 PM
Answer

Abhay Chaware

Rank: Junior Member

Posts: 36

Join Date: July 17, 2013

Recent Posts

I am getting same error .. I am using http://cmis.alfresco.com/cmisatom as my AtomPub binding. I have set the portal-ext.properties as per the blogs/documentation ... created and used same user as the default alfresco cmis repo user .. admin/admin .. it gives no error on liferay 6.1 console, but Documents/Media portal fails saying

Your request failed to complete.
Please verify your repository configuration parameters.

BTW, I am able to conenct to alfresco using admin/admin