Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
aryan sahu
youtube video in webcontent
May 7, 2012 12:54 PM
Answer

aryan sahu

Rank: Junior Member

Posts: 54

Join Date: April 6, 2012

Recent Posts

hello, how can i embed a youtube video in my webcontent. i used
 1
 2
 3<object classid="some classid"
 4        codebase="https://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" height="346" width="749">
 5  <param name="movie" value="I ENTERED MY YOUTUBE URL." />
 6
 7  <!-- this adds a param to object tag -->
 8  <param name="wmode" value="opaque" />
 9
10  <param name="quality" value="high" />
11  <param name="flashvars" value="ruta=null" />
12
13  <!-- don't forget to add it here too -->
14  <embed flashvars="somename=somevalue" height="..." pluginspage="http://www.macromedia.com/go/getflashplayer" quality="high" src="...movie url ..." type="application/x-shockwave-flash" width="..." wmode="opaque">
15  </embed>

its not giving any output. is it the correct way. thank you
Mayur Patel
RE: youtube video in webcontent
May 7, 2012 10:03 PM
Answer

Mayur Patel

Rank: Expert

Posts: 357

Join Date: November 17, 2010

Recent Posts

I've used below code, Can you check the same?

1<object style="height: 200px; width: 250px">
2                                <param name="movie" value="$ytUrl">
3                                <param name="allowFullScreen" value="true">
4                                <param name="allowScriptAccess" value="always">
5                                <embed src="$ytUrl" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="250" height="200" wmode="transparent">
6                            </object>


Thanks,
Mayur
aryan sahu
RE: youtube video in webcontent
May 7, 2012 11:18 PM
Answer

aryan sahu

Rank: Junior Member

Posts: 54

Join Date: April 6, 2012

Recent Posts

thank you mayur , i have figured it out .emoticon
TY Kim
RE: youtube video in webcontent
November 27, 2012 9:13 PM
Answer

TY Kim

Rank: New Member

Posts: 5

Join Date: November 13, 2012

Recent Posts

Dear,

I just copy your source to my page, but nothing happen.
I replaced "$ytUrl" with my youtube url. Anything I missed?
I just want embed youtube video file in my web contents.
Thanks in advance for your assistance.

Participate in the State of Liferay Community 2017. Help the community and even win some prizes!