Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Nilesh Gundecha
Border less portlet does not work while viewing first time
March 6, 2012 11:27 PM
Answer

Nilesh Gundecha

Rank: Regular Member

Posts: 196

Join Date: November 30, 2009

Recent Posts

Hi All,

I am able to configure my portlet to be borderless by setting the below tag in portlet.xml.

1<portlet-preferences>
2            <preference>
3            <name>portletSetupShowBorders</name>
4            <value>false</value>
5            </preference>
6        </portlet-preferences>


But the problem is that when any user views the portlet first time, he still sees the portlet border and title. But after he refresh the page, then the portlet starts looking right.
This happens only one time for one portlet instance.

I am using Liferay 6.1.

Did anyone notice this?

Regards,
Nilesh
Nilesh Gundecha
RE: Border less portlet does not work while viewing first time
March 12, 2012 2:33 AM
Answer

Nilesh Gundecha

Rank: Regular Member

Posts: 196

Join Date: November 30, 2009

Recent Posts

Any idea on this guys? Is it known issue?

Regards,

Nilesh
Mikel Goikoetxea
RE: Border less portlet does not work while viewing first time
March 26, 2012 3:02 AM
Answer

Mikel Goikoetxea

Rank: Junior Member

Posts: 56

Join Date: March 16, 2010

Recent Posts

Hi Nilesh,

You have an error in the label "name".
Try this:
1<portlet-preferences>
2    <preference>
3        <name>portlet-setup-show-borders</name>
4        <value>false</value>
5    </preference>
6</portlet-preferences>

Un saludo,

Mikel Goikoetxea Bilbao (@mgoibil)
B2B 2000
Hitoshi Ozawa
RE: Border less portlet does not work while viewing first time
March 26, 2012 3:35 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

The name changed in 6.1 so Nilesh got the name right.

http://stackoverflow.com/questions/9625139/is-it-possible-to-pass-the-version-number-of-liferay-into-a-themes-velocity-tem
Tejas Kanani
RE: Border less portlet does not work while viewing first time
May 7, 2012 3:39 AM
Answer

Tejas Kanani

Rank: Liferay Master

Posts: 655

Join Date: January 6, 2009

Recent Posts

Hi Nilesh,

Facing the same issue and checked for Liferay issues if somebody have created. But didn't find any so created issue in Liferay jira for the same.
LPS-27160
Nilesh Gundecha
RE: Border less portlet does not work while viewing first time
May 7, 2012 3:47 AM
Answer

Nilesh Gundecha

Rank: Regular Member

Posts: 196

Join Date: November 30, 2009

Recent Posts

Hi Tejas,

Ya this seems to be Liferay bug. However I had overcome this issue by using <use-default-template>false</use-default-template>.

Regards,
Nilesh

Tejas Kanani:
Hi Nilesh,

Facing the same issue and checked for Liferay issues if somebody have created. But didn't find any so created issue in Liferay jira for the same.
LPS-27160
Tejas Kanani
RE: Border less portlet does not work while viewing first time
May 7, 2012 3:50 AM
Answer

Tejas Kanani

Rank: Liferay Master

Posts: 655

Join Date: January 6, 2009

Recent Posts

Thanks Nilesh for sharing this.
This might be useful until we'll get fix from Liferay.

Regards,
TK
Atin Agarwal
RE: Border less portlet does not work while viewing first time
October 17, 2013 12:32 AM
Answer

Atin Agarwal

Rank: Junior Member

Posts: 86

Join Date: February 19, 2012

Recent Posts

Nilesh Gundecha:


However I had overcome this issue by using <use-default-template>false</use-default-template>.



But by using this workaround, even the configuration buttons become invisible.
They should be there atleast so as to drop the portlet at some other place or for any other configuration settings.

Is there any workaround just to disable the portlet borders. Issue in liferay is still unfixed.
Zsigmond Rab
RE: Border less portlet does not work while viewing first time
October 19, 2013 2:38 AM
Answer

Zsigmond Rab

LIFERAY STAFF

Rank: Liferay Master

Posts: 650

Join Date: January 4, 2010

Recent Posts

Hi Atin,

I think, this has been fixed at the LPS-37951 ticket.

Regards,
Zsigmond
Atin Agarwal
RE: Border less portlet does not work while viewing first time
October 24, 2013 11:21 PM
Answer

Atin Agarwal

Rank: Junior Member

Posts: 86

Join Date: February 19, 2012

Recent Posts

Hey Zsigmond,
I am using Liferay 6.1.2.
In LPS-37951 ticket, it is mentioned that we need to add a line -

PortletPreferences portletSetup = PortletPreferencesFactoryUtil.getStrictLayoutPortletSetup(layout, portletId);

where do i add this line??

Regards,
Atin
Zsigmond Rab
RE: Border less portlet does not work while viewing first time
October 27, 2013 12:39 AM
Answer

Zsigmond Rab

LIFERAY STAFF

Rank: Liferay Master

Posts: 650

Join Date: January 4, 2010

Recent Posts

Hi Atin,

see this commit on GitHub.

Regards,
Zsigmond