Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Shravan Babu
Error when using resourceLocalService.addResources
February 13, 2012 10:17 PM
Answer

Shravan Babu

Rank: New Member

Posts: 16

Join Date: November 17, 2011

Recent Posts

Hi,

I'm not able to persist the data when using resourceLocalService.addResources. Commenting this out the data is saved.
I have defined the portlet resources and added the path in portlet.properties as "resource.actions.configs=resource-actions/attend.xml". which doesn't help.
Please suggest.

Regards,
Shravan
Shravan Babu
RE: Error when using resourceLocalService.addResources
February 14, 2012 1:54 AM
Answer

Shravan Babu

Rank: New Member

Posts: 16

Join Date: November 17, 2011

Recent Posts

When i try to save the data, it shows an error "Unable to complete the request".
Serdar Ayalp
RE: Error when using resourceLocalService.addResources
August 1, 2012 10:08 AM
Answer

Serdar Ayalp

Rank: Junior Member

Posts: 45

Join Date: September 2, 2011

Recent Posts

Hi Shravan

Have you already found a solution for this Problem?

I also have the same problem. Data is written into database, but an error is thrown,

There are no actions associated with the resource interface de.iconate.portlet.gruendervaeter.service.model.MyEntityClassName

I also have defined the portlet resources and added the path in portlet.properties as resource.actions.configs=resource-actions/attend.xml
Carlos Fdo. Afanador M.
RE: Error when using resourceLocalService.addResources
September 20, 2012 2:12 PM
Answer

Carlos Fdo. Afanador M.

Rank: New Member

Posts: 14

Join Date: June 26, 2009

Recent Posts

Hi....

Someone has solved this problem or know why that occurs??

Thanks in advance
Philipp Schwarz
RE: Error when using resourceLocalService.addResources
October 31, 2012 10:14 AM
Answer

Philipp Schwarz

Rank: Junior Member

Posts: 29

Join Date: October 19, 2012

Recent Posts

Same here!

Anyone please?
Philipp Schwarz
RE: Error when using resourceLocalService.addResources
October 31, 2012 11:25 AM
Answer

Philipp Schwarz

Rank: Junior Member

Posts: 29

Join Date: October 19, 2012

Recent Posts

Found it:

It was an error in my xxxFromRequest() Method in the ActionUtil class.

WRONG:
1xxx.setCompanyId(themeDisplay.[b]getCompanyGroupId()[/b])


CORRECT:
1xxx.setCompanyId(themeDisplay.[b]getCompanyId()[/b])


Duh!