Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
MICHAIL MOUDATSOS
How to setup a connection to a node of an SQL Server cluster?
February 13, 2012 4:51 AM
Answer

MICHAIL MOUDATSOS

Rank: Regular Member

Posts: 110

Join Date: October 4, 2011

Recent Posts

Hello all,

I'm trying to setup a connection of my Liferay 6.0.6 installation tomcat bundle with a node of an SQL Server cluster at client site. It seems that the connection string I've provided does not work:
1 jdbc.default.driverClassName=net.sourceforge.jtds.jdbc.Driver
2 jdbc.default.url=jdbc:jtds:sqlserver://<ip>/<dbname>;instance=<instancename>
3 jdbc.default.username=<username>
4 jdbc.default.password=<password>

Any ideas what might be wrong? How can I achieve this?

Note that the connection is achievable through a SQL Server Management Studio using <ip>\<instancename> as the target server using SQL server authentication (not Windows authentication)

Thank you in advance!
Bijan Vakili
RE: How to setup a connection to a node of an SQL Server cluster?
February 13, 2012 9:11 PM
Answer

Bijan Vakili

Rank: Expert

Posts: 354

Join Date: March 10, 2009

Recent Posts

Are you able to telnet to the db server from the portal server?

Also, you may want to switch to the mssql driver; but that can be the topic for another post.

Let us know because the fact that it is a node of an SQL Server cluster doesn't make a difference from LR standpoint.
MICHAIL MOUDATSOS
RE: How to setup a connection to a node of an SQL Server cluster?
February 14, 2012 1:53 AM
Answer

MICHAIL MOUDATSOS

Rank: Regular Member

Posts: 110

Join Date: October 4, 2011

Recent Posts

Yes you're right, it shouldn't matter from the LR standpoint and it didn't.
For all those who might confront the same situation, that is, although all firewall settings were correctly set up the connection could not be established, the problem was at SQL server-side and was the following:
the sql server had a number of network interfaces; strangely enough their order in their definition list mattered! Changing the order and putting first the ip that the app server was using, solved the problem.
This is clearly an OS related issue which is so simple and thus hard to think to try out, so I hope I helped some ppl out there!