Forums

Home » Liferay Sync

Combination View Flat View Tree View
Threads [ Previous | Next ]
Rex Petersen
Failed to connect to server
February 1, 2012 9:05 PM
Answer

Rex Petersen

Rank: New Member

Posts: 11

Join Date: March 10, 2011

Recent Posts

After installing Sync, when entering Account Settings in the "Enter new account information" dialog, I get the message "Failed to connect to server" when attempting to connect to a local instance of LR6.1GA.

What are the requirements for the server to which Liferay Sync is attempting to connect?

So far I haven't seen a "Getting Started" doc which might cover this. Am I missing something?
Michael Young
RE: Failed to connect to server
February 1, 2012 9:46 PM
Answer

Michael Young

LIFERAY STAFF

Rank: Liferay Master

Posts: 847

Join Date: August 4, 2004

Recent Posts

Hey Rex,

We'll have a look at this. In the meantime, can you attach your log file?

They should be in user.home/.liferay-sync/logs

Thanks.
Rex Petersen
RE: Failed to connect to server
February 1, 2012 9:54 PM
Answer

Rex Petersen

Rank: New Member

Posts: 11

Join Date: March 10, 2011

Recent Posts

Hi Michael,

Here is the log file.

I just downloaded and installed this instance of LR6.1GA1 tonight.
Attachments: liferay-sync.log (4.0k)
Michael Young
RE: Failed to connect to server
February 1, 2012 10:07 PM
Answer

Michael Young

LIFERAY STAFF

Rank: Liferay Master

Posts: 847

Join Date: August 4, 2004

Recent Posts

It seems that Sync is not recognizing your server as a valid Liferay portal. Have you already started GA1 and completed the setup, logged in, etc? We'll have a better look at this tomorrow and try to reproduce this.
Rex Petersen
RE: Failed to connect to server
February 1, 2012 10:12 PM
Answer

Rex Petersen

Rank: New Member

Posts: 11

Join Date: March 10, 2011

Recent Posts

yes, in fact was logged while attempting to make the Sync connection.

Also, if I change the username or password it gives me a "username or password is incorrect" so it looks like it is communicating.

Anything in particular to look at on the server? Where would I find source for the ServerReleaseInfo class?
Dennis Ju
RE: Failed to connect to server
February 2, 2012 3:22 PM
Answer

Dennis Ju

LIFERAY STAFF

Rank: Regular Member

Posts: 187

Join Date: September 30, 2010

Recent Posts

It looks like we're not getting back the expected http headers when communicating to the portal.

Can you try installing the Firefox add-on "Live HTTP Headers" link and see what you're getting when you go to your portal? You may want to attach it as a file as there might be quite a bit of text.
Valentine KH
RE: Failed to connect to server
July 4, 2012 1:24 AM
Answer

Valentine KH

Rank: New Member

Posts: 3

Join Date: June 28, 2011

Recent Posts

Hi, Dennis

I've got the same problem. Runnning Sync with liferay-portal-6.1.0-ce-ga1. Any clue to resolve the problem?

Although tell me please what url Sync is connecting while identifying Liferay portal version and so on? I could check headers returning from that URL to help you.

Thx
Valentine KH
RE: Failed to connect to server
July 4, 2012 1:52 AM
Answer

Valentine KH

Rank: New Member

Posts: 3

Join Date: June 28, 2011

Recent Posts

From quick overview: start page returns me 'Liferay-Portal: Liferay Portal Community Edition 6.1.0 CE (Paton / Build 6100 / January 6, 2012)' header. I can see it from Firebug. Other headers are common and not liferay-oriented.

Moreover I managed to connect to localhost Liferay portal with Sync. Exactly the same version of portal (the same archive) is installed on remote server, which I cannot connect with Sync. Starpage headers are the same. Could you please tell me the URL that Sync connects to to prove Liferay version. Strange thing is I cannot see Sync network traffic while tryinf to log in with Fiddler....
Valentine KH
RE: Failed to connect to server
July 4, 2012 3:22 AM
Answer

Valentine KH

Rank: New Member

Posts: 3

Join Date: June 28, 2011

Recent Posts

Problem solved.

I monitored requests made by Sync with Fiddler and MS Network Monitor. There are 3 requests. The second is '/'. By default this returns main page. In my config home page was set to /home in Control Panel and start page was set to /home too. This caused http://serverurl/ path return 404. Switching to defults (or /) resolved problem.
Dennis Ju
RE: Failed to connect to server
July 6, 2012 12:23 PM
Answer

Dennis Ju

LIFERAY STAFF

Rank: Regular Member

Posts: 187

Join Date: September 30, 2010

Recent Posts

Hi Valentine,

Can you help me understand exactly what your configuration is? If this is a configuration bug, we should fix it.

So I understand your main page's "Friendly URL" was set to /home. But which setting are you referring to when you said "start page was set to /home too"?
Brett Lewinski
RE: Failed to connect to server
July 13, 2012 11:15 AM
Answer

Brett Lewinski

Rank: Junior Member

Posts: 53

Join Date: May 3, 2011

Recent Posts

Hi -

I have been experimenting with Liferay Sync. I have it connecting to my local Liferay 6.1 instance no problem. When I try to connect Liferay Sync to my remote 6.1 server I am getting a "peer not authenticated" message returned. Anybody have any idea whats going on or how I can fix this. Any help would be much appreciated.

Thanks in advance!
Brett
Dennis Ju
RE: Failed to connect to server
July 13, 2012 3:38 PM
Answer

Dennis Ju

LIFERAY STAFF

Rank: Regular Member

Posts: 187

Join Date: September 30, 2010

Recent Posts

Hi Brett,

Does your portal default to https? (does your portal URL always default to https://myportal.com)?
Brett Lewinski
RE: Failed to connect to server
July 16, 2012 6:32 AM
Answer

Brett Lewinski

Rank: Junior Member

Posts: 53

Join Date: May 3, 2011

Recent Posts

Dennis -

Thanks for the reply. Yes all of our servers are using https.

Thanks
Brett
Anonymous
RE: Failed to connect to server
July 16, 2012 8:12 AM
Answer

Anonymous

This is a known issue.

http://issues.liferay.com/browse/SYNC-364
SYNC-364 Sync cannot connect to portal through https

It should be fixed in an upcoming release.
Brett Lewinski
RE: Failed to connect to server
July 16, 2012 11:09 AM
Answer

Brett Lewinski

Rank: Junior Member

Posts: 53

Join Date: May 3, 2011

Recent Posts

Gail -

Thanks for the info, it is much appreciated! Any ideas on when this may be resolved?

Thanks Again!
Brett

Participate in the State of Liferay Community 2017. Help the community and even win some prizes!