Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
suresh vadlamudi
Liferay Remember me not working
January 31, 2012 11:56 PM
Answer

suresh vadlamudi

Rank: Junior Member

Posts: 33

Join Date: September 7, 2010

Recent Posts

Hi All,
I am facing a problem with liferay "Remember Me" option.I am using Liferay Community Edition 6.0.6 CE .. The problem is i am entering Email Address and Password for login and i checked the remember me check box to remember my credentials.But it seems this option is not working.When i logout and login again still it is asking for password and it is not showing the checkbox checked in auto matically.
I tried to put the entries like
company.security.auto.login=true
company.security.auto.login.max.age=31536000
in portal-ext.xml and restarted the server...still i am finding the same issue.
Could any one help me on this...

Thanks in advance
Suresh.Vadlamudi
suresh vadlamudi
RE: Liferay Remember me not working
February 1, 2012 5:16 AM
Answer

suresh vadlamudi

Rank: Junior Member

Posts: 33

Join Date: September 7, 2010

Recent Posts

Any suggestion on this?
Shinn Lok
RE: Liferay Remember me not working
February 1, 2012 11:03 AM
Answer

Shinn Lok

LIFERAY STAFF

Rank: Junior Member

Posts: 86

Join Date: January 14, 2011

Recent Posts

Hi,

I believe the intended function of "Remember me" is different from your expectations. When you check remember me and log in, a session cookie is created for your browser. This means you could close your browser and remain signed in the next time you visit the portal. You will continue to be logged in until either company.security.auto.login.max.age is expired, you log out, or you clear your cookies.
suresh vadlamudi
RE: Liferay Remember me not working
February 2, 2012 9:01 PM
Answer

suresh vadlamudi

Rank: Junior Member

Posts: 33

Join Date: September 7, 2010

Recent Posts

Hi Shinn,

Thanks for your reply..Still i am not clear about "Remember Me " checkbox..even i select that option or not if i put the portal-ext.properties entries ...and not logout from portal or not cleared the browser cookies ....still it is remain signed in the next time when i visit the portal .If this is the case what is the perpose of "Remember Me " option.If you don't mine could you please elaborate how this feature got implemented.

Thanks in advance
Suresh.Vadlamudi
Shinn Lok
RE: Liferay Remember me not working
February 3, 2012 12:43 AM
Answer

Shinn Lok

LIFERAY STAFF

Rank: Junior Member

Posts: 86

Join Date: January 14, 2011

Recent Posts

Hi Suresh,

Try the following tests:

Test A-
1. Sign in to Liferay.com, with Remember Me checked.
2. Close your browser.. (not just closing the tab if you have multiple tabs or navigating away from the page)
3. Open your browser and go to Liferay.com

Observe that you are signed in.

Test B-
1. Sign in to Liferay.com with Remember Me unchecked
2. Close your browser.. (not just closing the tab if you have multiple tabs or navigating away from the page)
3. Open your browser and go to Liferay.com

Observe that you are signed out.

The reason this happens is because each time the browser is closed, the session is killed unless it is told otherwise.
Aasif Bihari
RE: Liferay Remember me not working
April 2, 2012 12:20 AM
Answer

Aasif Bihari

Rank: New Member

Posts: 7

Join Date: January 10, 2012

Recent Posts

I am doing Test A as per you I should remain signed in if
1) I check remember me check box and sign in with correct credentials

but when I closed the browser all tab without signing out I am not able to login directly but it asks for password, and any1 help.
Jitendra Rajput
RE: Liferay Remember me not working
April 2, 2012 1:03 AM
Answer

Jitendra Rajput

Rank: Liferay Master

Posts: 858

Join Date: January 7, 2011

Recent Posts

Have a look to similar kind of thread..

http://www.liferay.com/community/forums/-/message_boards/message/12976197

http://www.liferay.com/community/forums/-/message_boards/message/12937334
Brendan J Mullan
RE: Liferay Remember me not working
July 31, 2012 3:40 AM
Answer

Brendan J Mullan

Rank: Junior Member

Posts: 28

Join Date: January 26, 2007

Recent Posts

The 'Remember Me' function is not working for me in Liferay 6.0.5 CE either.

In my instance of Liferay each of the following properties is set as follows:

company.security.auto.login=true
company.security.auto.login.max.age=31536000
session.enable.persistent.cookies=true

I have followed Shinn's instructions above for Test A and find that I am logged out when I restart the browser. If I restart only the browser tab then I find I am logged in. However whether I tick the 'Remember Me' box or not, restarting only the browser tab shows that I remained logged in.

This happens whether I use IE8, IE9, Chrome, or Firefox.

Can anyone advise please? TIA