Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
copying page isn't working gordon daniels November 28, 2011 8:17 PM
RE: copying page isn't working Sandeep Nair November 28, 2011 10:30 PM
RE: copying page isn't working Sandeep Nair November 28, 2011 10:34 PM
RE: copying page isn't working Sagar A Vyas November 28, 2011 11:22 PM
RE: copying page isn't working Sandeep Nair November 28, 2011 11:33 PM
RE: copying page isn't working Sagar A Vyas November 28, 2011 11:39 PM
RE: copying page isn't working Sandeep Nair November 28, 2011 11:42 PM
RE: copying page isn't working Nagendra Kumar Busam November 28, 2011 11:58 PM
RE: copying page isn't working Sagar A Vyas November 29, 2011 12:05 AM
RE: copying page isn't working gordon daniels November 29, 2011 6:03 AM
RE: copying page isn't working Sandeep Nair November 29, 2011 6:18 AM
RE: copying page isn't working gordon daniels November 29, 2011 6:30 AM
RE: copying page isn't working gordon daniels November 29, 2011 7:07 AM
RE: copying page isn't working Sagar A Vyas November 29, 2011 8:08 AM
RE: copying page isn't working Nagendra Kumar Busam November 29, 2011 8:28 AM
RE: copying page isn't working gordon daniels November 29, 2011 11:02 AM
RE: copying page isn't working gordon daniels November 29, 2011 11:45 AM
RE: copying page isn't working Sagar A Vyas November 29, 2011 10:27 PM
RE: copying page isn't working Sandeep Nair November 29, 2011 10:29 PM
RE: copying page isn't working gordon daniels November 30, 2011 5:19 AM
RE: copying page isn't working Sandeep Nair November 30, 2011 5:51 AM
RE: copying page isn't working Sandeep Nair November 30, 2011 6:07 AM
RE: copying page isn't working Carolyn Curtis September 19, 2012 6:34 PM
gordon daniels
copying page isn't working
November 28, 2011 8:17 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

I have a page that I want to copy and use on new page. I created new page and selected copy and then save. Go to new page and content is there. So far so good, but if I edit the content then the original page that I copied is also edited.

Am I doing something wrong?

thanks
Sandeep Nair
RE: copying page isn't working
November 28, 2011 10:30 PM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

No it is expected behavior. Note when you do copy page, you copy the the same portlet instance(in case of instanceable portlet like web content portlet). Since both the page are having same instance of the portlet, whatever change you make in one will also be reflected to the other.

I had actually benefited from such behavior, as i want two asset publisher portlet in two different pages, one having summary view and one detailed. So i copied the page and then in the page where i had configured asset publisher to show summary view, i linked the urls of the page to the one having detailed view.

Regards,
Sandeep
Sandeep Nair
RE: copying page isn't working
November 28, 2011 10:34 PM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Having said the above you can always go and change the preferences of the portlet to have both the same instance having different webcontent
Sagar A Vyas
RE: copying page isn't working
November 28, 2011 11:22 PM
Answer

Sagar A Vyas

Rank: Liferay Master

Posts: 657

Join Date: April 17, 2009

Recent Posts

Hi Sandeep,

Please correct me if i understood wrong here.

Gordon , talks about "Copy page" functionality available in page ?

If so, then i have done this but i wont be able to reproduce same.

I guess I am pointing to different location please tell me a step for same.

Thanks,
Sagar Vyas
Sandeep Nair
RE: copying page isn't working
November 28, 2011 11:33 PM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Go to manage page. Create a new page. After the page is created, go to Page tab and there you see option to copy page content from other pages.

Regards,
Sandeep
Sagar A Vyas
RE: copying page isn't working
November 28, 2011 11:39 PM
Answer

Sagar A Vyas

Rank: Liferay Master

Posts: 657

Join Date: April 17, 2009

Recent Posts

Sandeep Nair:
Go to manage page. Create a new page. After the page is created, go to Page tab and there you see option to copy page content from other pages.

Regards,
Sandeep


Hi Sandeep,

Ya I have done this before also i have copy some page it will apply all changes like theme and all from parent page.

But i want reproduce what Gordon said. How to do that ?

Thanks,
Sagar Vyas
Sandeep Nair
RE: copying page isn't working
November 28, 2011 11:42 PM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Put a webcontent display portlet on parent page. Create some content in it. Now use this page for copying to another page. Now in either of the page when you edit the webcontent you will see the content gets changed at both the pages. He does not want that
Nagendra Kumar Busam
RE: copying page isn't working
November 28, 2011 11:58 PM
Answer

Nagendra Kumar Busam

Rank: Liferay Master

Posts: 653

Join Date: July 7, 2009

Recent Posts

Any asset (check the available assets in Liferay under asset publisher portlet for ref) related changes are not specific to a page/portlet. Only other settings such preferences/look & feel/configuration are portlet specific.
Sagar A Vyas
RE: copying page isn't working
November 29, 2011 12:05 AM
Answer

Sagar A Vyas

Rank: Liferay Master

Posts: 657

Join Date: April 17, 2009

Recent Posts

Sandeep Nair:
Put a webcontent display portlet on parent page. Create some content in it. Now use this page for copying to another page. Now in either of the page when you edit the webcontent you will see the content gets changed at both the pages. He does not want that


Ohhkk ..Now I am getting all scenario Thanks buddy emoticon

Regards,
Sagar Vyas
gordon daniels
RE: copying page isn't working
November 29, 2011 6:03 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

Sandeep,

thanks for the reply. If I understand you correctly after I copy page to new page, I can change the page or portlets preferences so content won't change on orignal page?

thanks again for your replies
Sandeep Nair
RE: copying page isn't working
November 29, 2011 6:18 AM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Yes if you update preference in any of the portlets (copied page or source page), it is for that page only. So if you go change a webcontent from configuration, it will be for that page only. You can try it to see if its working

Regards
Sandeep
gordon daniels
RE: copying page isn't working
November 29, 2011 6:30 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

thanks so much. Will give it a try.
gordon daniels
RE: copying page isn't working
November 29, 2011 7:07 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

Sandeep,

Okay, I copied a source page and all went as expected with that. I then clicked on a web content portlet on new page configuration. I don't see any thing called 'Preferences', so I changed 'Scope' to current page only but the behavior still exists. It updates original source.

Would you mind being a little more specific about what I changed on portlet so that it does not update original source?

thanks so much
Sagar A Vyas
RE: copying page isn't working
November 29, 2011 8:08 AM
Answer

Sagar A Vyas

Rank: Liferay Master

Posts: 657

Join Date: April 17, 2009

Recent Posts

Hi Gordon,

Okay, I copied a source page and all went as expected with that. I then clicked on a web content portlet on new page configuration. I don't see any thing called 'Preferences', so I changed 'Scope' to current page only but the behavior still exists. It updates original source.


Yes you are on the same page.Anything related to portlet configuration called preferences of that portlet. (it stores as preference in DB )

By default its scope preference store as default but if you switch it to page then scope preference would be limited to page only.

Thanks,
Sagar V yas
Nagendra Kumar Busam
RE: copying page isn't working
November 29, 2011 8:28 AM
Answer

Nagendra Kumar Busam

Rank: Liferay Master

Posts: 653

Join Date: July 7, 2009

Recent Posts

Click on configuration section of the portlet & try to point select another new web content item. This way portlets in both pages will be referring to different assets
gordon daniels
RE: copying page isn't working
November 29, 2011 11:02 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

thanks for the replies. I will give it a try and let the forum know the outcome.

thanks
gordon daniels
RE: copying page isn't working
November 29, 2011 11:45 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

Well guys, I can't get it to work. I changed the scope to current page and my places to current page and it still updates the original source. One time it actually worked using those same steps. But the next time it didn't.

Is this a bug?
Sagar A Vyas
RE: copying page isn't working
November 29, 2011 10:27 PM
Answer

Sagar A Vyas

Rank: Liferay Master

Posts: 657

Join Date: April 17, 2009

Recent Posts

gordon daniels:
Well guys, I can't get it to work. I changed the scope to current page and my places to current page and it still updates the original source. One time it actually worked using those same steps. But the next time it didn't.

Is this a bug?


Hi Gordon,

Remove cookies of your browser may it pointing to old preferences.

or

Try it on other browser.

Thanks,
Sagar Vyas
Sandeep Nair
RE: copying page isn't working
November 29, 2011 10:29 PM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

No gordon. Follow the steps.
Create two webcontents from control panel(For this test say Content A and Content emoticon

Create a page and select webcontent Content A in this page.

Create another page. Use the copy page.

-- Check---

Both the page now has same web content Content A

In the page that you last created (the copied page), click on configuration button( Here select Content emoticon

--- Check--

Now this page has content B and the original page still has Content A

Regards,
Sandeep
gordon daniels
RE: copying page isn't working
November 30, 2011 5:19 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 724

Join Date: August 23, 2008

Recent Posts

Sandeep,

I really appreciate your help. However, that is not what I am trying to do. I have several pages with layout and content that I want to use multiple times. So, creating new pages that are copies of those original pages saves time.

The problem is that the new pages when edited also edit original source page. Your last post is not what I want to do. I am not sure if its the time saver approach I was looking for :-).

I guess my issue is that if one copies a page and edits new page it shouldn't update the original. I don't understand why liferay makes this complicated. Just my two cents worth of opinion.

thanks
Sandeep Nair
RE: copying page isn't working
November 30, 2011 5:51 AM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Have you tried Site Templates? I am not sure about the content, though i believe if i place the webcontent portlet it cant be configured since template is just a blue print of how many pages would be there, what would be the layout and which all portlets are arranged in the page. Let me try if webcontent(with actual content) in template does the job

Regards,
Sandeep
Sandeep Nair
RE: copying page isn't working
November 30, 2011 6:07 AM
Answer

Sandeep Nair

Rank: Liferay Legend

Posts: 1721

Join Date: November 5, 2008

Recent Posts

Ok I tried both Site template(for set of pages) and Page Template(for a single page) an both have same issue as u mentioned.

Can you try remote publishing. Create a community with some pages and web content. Then create a new community. Note its group id

And do one time remote publishing to the new community.

http://www.liferay.com/community/wiki/-/wiki/Main/Staging+-+6.0

Regards,
Sandeep
Carolyn Curtis
RE: copying page isn't working
September 19, 2012 6:34 PM
Answer

Carolyn Curtis

Rank: New Member

Posts: 4

Join Date: September 4, 2012

Recent Posts

I am trying to not only copy a page, but copy the page and all of its child pages.
What I want to do is create a sample page hierarchy
Page1
Page1a
Page1b
Page1c
Page1c-1
Page1c-2
Page1c-3

That I can reuse over and over again on my site. Is there anyway to do this with LR 6.1?