Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Miguel Ángel Júlvez
Performance problem in Liferay 6.0.6 CE
September 19, 2011 12:25 AM
Answer

Miguel Ángel Júlvez

Rank: Junior Member

Posts: 61

Join Date: March 29, 2011

Recent Posts

Hi!!

I'm having a performance problem that I don't know fix it easily.

I'have a structure with 70 or 80 fields form. When I try edit a web content with that structure in the control panel, my browser firefox and ie crash (google chrome works fine).

I used firebug to see what it was happening and i coud be that the problem is a lot of javascript files loading in each field form (for example, query.js is loaded 70 or 80 times, one per field form).

It's true that the cache browser works fine and load almost all javscript files but it's not enough. I see that the time spended by the request for all this javascript files is too much (1minute a 30 seconds), with cache browser working inclusive.

Any solution??

Thanks!!
Raja Nagendra Kumar
RE: Performance problem in Liferay 6.0.6 CE
September 19, 2011 12:30 AM
Answer

Raja Nagendra Kumar

Rank: Expert

Posts: 484

Join Date: March 1, 2006

Recent Posts

Could you show the jsp or script which is creating the form..

loading jquery per field is not the right approach..

See this..
http://www.liferay.com/web/nathan.cavanaugh/blog/-/blogs/using-jquery-or-any-javascript-library-in-liferay-6-0

It shows the ways to load jquery..

Regards,
Nagendra
Miguel Ángel Júlvez
RE: Performance problem in Liferay 6.0.6 CE
September 19, 2011 12:58 AM
Answer

Miguel Ángel Júlvez

Rank: Junior Member

Posts: 61

Join Date: March 29, 2011

Recent Posts

Raja Nagendra Kumar:
Could you show the jsp or script which is creating the form..

loading jquery per field is not the right approach..

See this..
http://www.liferay.com/web/nathan.cavanaugh/blog/-/blogs/using-jquery-or-any-javascript-library-in-liferay-6-0

It shows the ways to load jquery..

Regards,
Nagendra


Yeah, I know. But that's the way that structures works in liferay. I guess I can fix it overwritting all taglib in ¿aui? or something similar.... emoticon

Regards!
Raja Nagendra Kumar
RE: Performance problem in Liferay 6.0.6 CE
September 19, 2011 3:17 AM
Answer

Raja Nagendra Kumar

Rank: Expert

Posts: 484

Join Date: March 1, 2006

Recent Posts

OK you use aui..

Is the perf issue with your form or with any default forms provided outof the box with liferay... or is it in both..

If the issue is with your form, pl. show your view code..

Regards,
Nagendra
Miguel Ángel Júlvez
RE: Performance problem in Liferay 6.0.6 CE
September 20, 2011 8:30 AM
Answer

Miguel Ángel Júlvez

Rank: Junior Member

Posts: 61

Join Date: March 29, 2011

Recent Posts

Raja Nagendra Kumar:
OK you use aui..

Is the perf issue with your form or with any default forms provided outof the box with liferay... or is it in both..

If the issue is with your form, pl. show your view code..

Regards,
Nagendra


Hi Nagendra,

It's with any default form provided outofthebox for liferay portal. It happens in any field form of a web content inside of control panel. If you've a few of field forms in the structure you don't realize, but if you insert a web content associated to a structure with 70 or 80 fields forms you can view it

Thanks!